8 Replies Latest reply on Jul 2, 2014 1:18 PM by techt

    Permissions for Backups folder

    taylorsharpe

      I just did a new FMS 13.0.2.295 install with a brand new out of the box Mac Mini 10.9.4. I'm trying to set an external drive for my backups and assign the folder. I have done this many times before. You simply have to get the POSIX permissions correct and whenever it didn't work, it was because I had not set the permissions. However, I can't seem to get it to work this time. Granted this is the first time I've ever worked on 10.9.4, but I can't see what that would have to do with it. I've created a folder "FM Backups" on volume "Backups" which is a USB drive. It shows fine in the Finder. You can see below the folder on the right, the "Get Info" with permissions on the left and that the permissions are set correctly. In the background in the middle you'll see the Admin Console folders tab where you select the folder destinations and as you can see, I have the folder correctly named including the slash at the end. And this path will not validate. I've deleted and recreated the folder. Maybe I'm just an idiot and missing something. It is frustrating because I have done this many times in the past on different Mac servers. Well if anyone can see my mistake or have any suggestions, please let me know. Thanks for any input.

       

      permissions.jpg

        • 1. Re: Permissions for Backups folder
          mikebeargie

          long shot, but I'd remove the space out of "FM Backups", I seem to recall that spaces in file paths on NTFS formatted drives had caused me issues before, but I could be making that up.

           

          Also suspicious is that the drive path in info is listed as "Volumes/Backups", have you tried making your path "filemac:/Volumes/Backups/FM Backups" ?

           

          Also, have you tried removing the trailing slash?

           

          Just a few things to try, which I'm sure you've already done. Good luck.

          • 2. Re: Permissions for Backups folder
            taylorsharpe

            I tried renaming it "Backups", but that didnt' work either.  The trailing slash is a requirement and results in an error if you leave it off.  I just tried it to confirm though.  Anyway, good ideas and let me know if you can think of any others. 

            • 3. Re: Permissions for Backups folder
              ChadAdams

              May seem silly, but is there any chance the flash drive or the folder have a trailing space in their name?

              • 4. Re: Permissions for Backups folder
                wimdecorte

                You may want to use a utility like "BatchMod", it shows a lot more info than Get Info does.

                 

                Also, it looks like you are using a time machine volume as the backup destination?  I wouldn't do that, leave that disk to time machine alone, it can get very busy and you don't want to hold up your progressive or regular FMS backups because of that.

                • 5. Re: Permissions for Backups folder
                  taylorsharpe

                  Thanks, Chad and Wim.  I have confirmed there are no spaces and manually retyped it several times, copied it from a LS from terminal and various other things to confirm it is correct.  I likewise can't enable an additional database folder on this drive or create a Progressive Backups folder.  Their path validations in the Admin console also fail. 

                   

                  Regarding Time Machine on same volume, it was all I could do to get them to buy a new server and a backup drive and there are only 3 people using it.  So it is a compromise.  I agree with your general advice though, Wim, but this is best I could do with these guys.  Actually, I had to tell them I would not work for them if they did not buy new hardware and upgrade to 13.  The things you have to do to get clients to upgrade <grin>. 

                   

                  Wim, yes, I like BatChmod and have used it before.  It is a nice user interface for changing POSIX permissions as well as removing ACLs.  I had done the permissions changes in Terminal which normally works for me.  Just to confirm, I downloaded BatChmod and checked out the folder.  There were no xattrs and it was not locked.  I believe those are the things BatChmod shows that you can't see in Get Info.  The permissions still looked correct to me.  Attached is the Backups folder (note I tried renaming it from "FM Backups" to avoid the space issue in the file path). 

                   

                  permissions2.jpg

                   

                  Thanks for the ideas and suggestions and let me know if you have any other ideas. 

                  • 6. Re: Permissions for Backups folder
                    ChadAdams

                     

                    Thanks for the ideas and suggestions and let me know if you have any other ideas. 

                     

                    Disk Utility. Repair Disk Permissions. Has fixed some weird behavior for me in the past :-)

                    • 7. Re: Permissions for Backups folder
                      taylorsharpe

                      Good idea Chad and I had not thought of that.  Actually, I was fed up with it, so I did a complete erase of the drive and recreated the folder and used BatChmod to set the permissions.  It still will not let me assign and validate any folder paths with Admin Console to this drive. 

                       

                      Tonight when they are off the server, I'm going to uninstall FMS and reinstall and see if that makes any difference. 

                      • 8. Re: Permissions for Backups folder
                        techt

                        Looking forward to your results. I have external RAID drives with two of my servers, one a FMSA12 and the other a FMS13. FMSA12 is fine The folders I initially set up on the mini with FMS13 still work, but it seems that since the last update or so (I'm guessing), none of additional folders I've created work - basically, the same problem you're reporting.

                         

                        I don't know if the problem still exists, but when FMS13 was released, installing it on a Mac mini with OS X Server would break the new Admin Console, forcing a terminal shut down of FMS and a rebuild of the mini without server to resolve the problem.

                         

                        Good luck,


                        TT