3 Replies Latest reply on Jul 6, 2014 10:59 AM by mramsay21104

    Create Runtime in Mavericks - FMSTRS.dls and info.plist errors

    mramsay21104

      For a few months I was able to create runtimes in Mavericks with FM12 Advanced at will. Several days ago my fortunes turned. I get two messages when the runtime engine is Copying Solutions Files - Internal Runtime Libraries. As the FMStrs.dls tries to load - "the action cannot be performed because the required table is missing." Some other FMStrs.dls files load fine. Alss during Copying Solution Files, when info.plist comes, I get "file is locked or in use" for one instance. The only thing done recently is hook up a new disk drive by firewire and operate Time Machine. I have looked in resource folders and checked that all FMStrs files are unlocked. I have redownloaded FM12 to no avail. I have repaired disk permissions. I have checked all the FMStrs.dls files in the language folders and they are all unlocked. Permission to write to them is only granted to the System. The info.plist files in the top directory of the Runtime app and Filemaker Pro Advanced app are all unlocked and full read/write permission. I threw out old Filemaker version files nearer to the root directory. Nothing changes. Anybody have a solution to this problem?

        • 1. Re: Create Runtime in Mavericks - FMSTRS.dls and info.plist errors
          ChadAdams

          Do you get the same error regardless of the solution you are using to create the runtime?  What happens if you create a new empty file or use one of the starter solutions and then try to create a runtime from it...same thing?

          1 of 1 people found this helpful
          • 2. Re: Create Runtime in Mavericks - FMSTRS.dls and info.plist errors
            mramsay21104

            Chad,

            I compile two fmp12 files.  I compile using a Settings file which worked before these error messages appeared.  I learned two things doing your suggestion.  The Starter solutions window is empty.  That should not be.  The second is that I tried file versions that compiled into runtimes successfully before.  This time they showed the same errors as my recent files.  So the problem is with the Filemaker app on my computer.   I will discard it and reinstall it - again.  Any further ideas are welcome!

            • 3. Re: Create Runtime in Mavericks - FMSTRS.dls and info.plist errors
              mramsay21104

               

              Hi Peter,

               

               

              This is the fix that worked.  It came from PeterDoern in reply to someone who had an FM 11 runtime creation problem.  This one fix also took care of the FMStrs.dls not loading.  I did not have to do anything to these .dls files.  Fixing info.plist as below fixed all problems.

               

              Adam, I tried to compile an earlier version that did once work, but it did not improve matters.

               

              How I got in this mess in the first place is that I must have moved a folder or app file in the FM folder to another place within it.  My desktop was slow so that this could have happened without me noticing. Repairing disk permissions restored speed. 

               

              ===========================

              I had the same problem with FMPA 13 on OS X 10.9.1. Here's how I fixed it:

               

              1. Navigate to the folder containing Filemaker.

              2. Drill down to FMI Runtime Resources/Internal Runtime Libraries

              3. Control- or right-click on Runtime and select Show Package Contents

              4. Open the Contents folder

              5. Select info.plist and Get Info

              6. Change Sharing and Permissions (at the very bottom of the Get Info window) so that everyone can read and write.

               

              Changes should take effect immediately.

               

               

              Peter Doern