2 Replies Latest reply on Jul 17, 2014 6:53 AM by Get(3rdRockData)

    Developer Utility is not Updating External Data Source Names When Renaming Database Files

    Get(3rdRockData)

      I'm trying to do a routine renaming of database files and when I run them through the Developer Utilities in FMPA 13 it renames them but doesn't update their External Data References.

       

      For example, I have a file named "3RD_GUI" and a file name "3RD_Data" which reference each other as external data sources, but when I run them through the utility to rename them 3RD_GUI_Dev" and "3RD_Data_Dev", the renaming of the files takes place but their external file references don't update as I'd expect.

       

      This is something we do frequently when we want to make copies for our development and staging servers and I've never encountered this problem before. I've run copies through the recovery process, found no problems reported in recovery and then tried to rename the recovered copies, but I still get the same results ... 3RD_GUI_Dev still references 3RD_Data, and 3RD_Data_Dev still references 3RD_GUI.

       

      Has anyone seen this and know what could be causing it? I really need to get these files deployed as dev files on the dev server ASAP so I can get on with development.

       

      Thanks in advance!

       

      -Kent