1 2 Previous Next 18 Replies Latest reply on Nov 17, 2015 12:49 AM by disabled_kylerjphillips

    Webdirect Error

    devonell

      Can anyone advise why when attempting to access Webdirect on LAN or WAN, I receive the error: "Custom Web Publishing Technology Disabled ; WebDirect is turned off. I double check. WebDirect is turned on. I try to uncheck and then check the checkbox to turn WebDirect on or off and then after clicking "Save" to save changes, receive a Filemaker Admin Server Console dialog box that states: "You have unsaved changes. The Web Publishing Engine must be restarted to apply the changes. Do you want to save and restart or revert the changes and exit. I click the button "Save and Restart" I try to access via WebDirect and receive the same error WebDirect is turned off. How do I fix this. I'm able to access the files via FMAdvanced and FMGO but not WebDirect, regardless of browser I utilize. thanks for you help.

        • 1. Re: Webdirect Error
          mikebeargie

          Server OS?

          FMS Version?

          Did you update Java independently of filemaker?

           

          FMGo/Pro do not use the web publishing engine so they would not be affected by WPE being offline.

           

          I was trying to troubleshoot this same issue with a user at devcon last night in the lobby. We determined that the windows server java install was updated independently of filemaker server. Since the web publishing engine does depend on Java, our theory was that uninstalling the java update and reinstalling FMS13/13.0v2 might correct it.

           

          Unfortunately I left before the reinstall was performed so I'm not sure that corrected the issue. When I run into that user I will ask and report back here.

          • 2. Re: Webdirect Error
            devonell

            Great, thanks for the help Mike.  I'll try that this evening.  I think you're correct as the logs indicate that Java was updated.  I hope you're enjoying DEVCON.  I wish I was there.  It's been about 5 years since I attended.  Maybe next year.

            • 3. Re: Webdirect Error
              devonell

              Well, I uninstalled the Java update, and ATTEMPTED to reinstalled FMS13/13.03.300 but now I'm receiving the error ports 80 and 443 must  be available.  Had this error a few months ago.  Can't remember how I fixed it but will research a bit and figure this out.  I guess the main concern is if FMS13 Web Publishing requires / depends on Java, it would be nice if Filemaker corrected the issue caused when Java gets update... as we all know, periodic Java updates happen on a regular basis.  It's quite annoying to have to reinstall all the time. 

              • 4. Re: Webdirect Error
                devonell

                Problem resolved after doing the following

                First, uninstall these components from the Control Panel:

                a. FileMaker Server 13
                b. Bonjour
                c. All installed versions of Java
                d. Microsoft Visual C++ 2012 Redistributable (if you see earlier versions of this, don't worry about those)
                e. The four parts of the Application Request Routing application (if you don't see all four parts, remove what's there):
                --Microsoft Application Request Routing 2.5 or 3.0 (either one)
                --IIS URL Rewrite Module 2
                --Microsoft External Cache Version 1 for IIS 7
                --Microsoft Web Farm Framework
                Stop all services that port 80 and 443 that are using or listening (this was a problem)
                Then reinstall from a full installer.

                • 5. Re: Webdirect Error
                  mikebeargie

                  Thank you for the extensive followup. I had only confirmed yesterday that uninstalling FMS/Java and reinstalling FMS did NOT correct the original problem. I described this issue to an FMI engineer at Devcon and submitted a bug report.

                  • 6. Re: Webdirect Error
                    CarolHunneyman

                    I am getting the same message: Custom Web Publishing Technology disabled; WebDirect is turned OFF. The kicker is that it happened on Windows Server at one site, and also on my iMac (Yosemite) Dev Server at home. The Windows Server happened just this past week. Not sure when the iMac server stopped working (but is recent). I am not looking forward to two re-installations.

                    • 7. Re: Webdirect Error
                      CarolHunneyman

                      After 2 re-installs of server last night, I called support this morning. Issue was resolved from the admin console:

                      1 - Select SERVER dropdown in the upper right corner

                      2 - Select EDIT DEPLOYMENT and run through the wizard (again).

                       

                      Although this wizard ran after both re-installs, running it AGAIN from EDIT DEPLOYMENT did the trick. I remember now coming across this "secret" in the past, but forgot to try it. My "broken" WedDirect now works.Hope it works for you.

                      • 8. Re: Webdirect Error
                        thong127

                        Hello,

                        How can I stop all services that port 80 and 443? where to find them?

                        Thanks.

                        • 9. Re: Webdirect Error
                          devonell

                          Thank you!  Oh my goodness.  I remember the same thing.  Thanks for this and sorry for the delayed reply.

                           

                           

                          • 10. Re: Webdirect Error
                            jaytyo

                            Anyone have an ideas where to go if this process does not work?  I am getting the same error message and have tried recycling the server box, FileMaker Server, web publishing and WedDirect.  After seeing the above idea, I even tried that.   Noting has solved the issue.  This started just days ago, perhaps when the server was shutdown due an external issue.

                             

                            Thanks,

                             

                            Jay

                            • 11. Re: Webdirect Error
                              mikebeargie

                              Did your server run java updates two days ago? >90% of the issues with FMS I've ever seen where a server was working then stopped, has been when an unchecked java update was run.

                              • 12. Re: Webdirect Error
                                jaytyo

                                Mike, thanks for your reply.  Given the fact this started when the server rebooted the other day, my first thought was an "errant" java update.  I looked on the server and it is still running what I believe is the same version as before, 1.7.51.  My test/dev server has the same version and it is working fine.

                                 

                                Thanks,

                                 

                                Jay

                                • 13. Re: Webdirect Error
                                  mikebeargie

                                  Have you just tried to restart it in command line via FMSADMIN ?

                                  • 14. Re: Webdirect Error
                                    jaytyo

                                    No.  I'm not even sure how to do that.

                                    1 2 Previous Next