7 Replies Latest reply on Aug 6, 2014 10:21 AM by nella

    Merge Field

    nella

      I am getting unwanted spaces between my lines of text.

      What is the cure for this?

       

      Thank you

      merge field.jpg

        • 1. Re: Merge Field
          filemaker_mmfg

          Substitute (your_field; "¶"; "")

          • 2. Re: Merge Field
            nella

            Sorry, I'm not getting it.

             

             

            <<Suppliers::Supplier_Company>>

            <<Suppliers::Supplier_address1>>

            <<Suppliers::Supplier_City>>, <<Suppliers::prov_state>>

            <<Suppliers::Supplier_PostalCode>>

            Ph: <<Suppliers::Phone>>

            • 3. Re: Merge Field
              AlanStirling

              Hi Nella

               

              Looking at the image you attached, there is no reason for the blank lines to appear.

               

              However, you appear to have entered data into the various address fields, so as to test the results of positioning the merge fields on your layout.

               

              The some of the fields that you have entered data into, would appear to have a 'Return' character at the end of the word. This would be in the fields directly above the blank lines. So go back to these fields in the same record that you used to take the screen shot and highlight the whole field (Double-click) and re-type the entry, but without pressing the 'Return' key at the end.

               

              This should fix this problem.

               

              Best wishes - Alan Stirling, London UK.

               

               

              Alan Stirling Technology Ltd, 135 Lisson Grove, London NW1 6UP

              +44 (0) 20 7724 2456 - alan@ast.fm - www.ast.fm.

              FileMaker Certified Developer for versions; 7 8 9 10 11 12 13.

              • 4. Re: Merge Field
                erolst

                You have unwanted CRs in the data fields that the merge fields are based on; this causes the visible linebreaks.

                 

                First step would be to clean your existing data by applying the command Replace Field Contents to each of the address fields.

                 

                Show all Records, then enter one of the field, call Replace Field Contents and use the expression

                 

                Substitute ( YourTable::<theRespectiveField> ; ¶ ; "" )

                 

                with the Calculated Result option

                 

                IMPORTANT: Create a backup of your file first!

                A Replace Field Contents command/step cannot be undone. If you made a mistake, delete the file and start over with the backup (after creating a new backup, of course … )

                 

                Next step: prevent this from happening again.

                 

                You could add the same expression as an auto-enter calculation to your fields:

                 

                Substitute ( self ; ¶ ; "" ) // can use the exact same version for each field

                 

                and make sure to uncheck the “Do not replace …” option; now any return typed into one of these fields will automatically be deleted.

                • 5. Re: Merge Field
                  beverly

                  Apologies if this has been suggested.

                  1. If one "block" of text, many merge fields - make sure alignment of the text in the block is "Top". Then check the sliding preference of the block.

                  Or...

                  2. To avoid blank lines, I've been putting such text into an auto-enter field with calc like this:

                   

                  List

                  ( address1

                  ; address 2

                  ; city & " " & Upper(state_abbrev) & " " & zip

                  ; "Ph " & phone

                  )

                   

                  This naturally slides the text up and left removing blank lines.

                   

                  -- sent from myPhone --

                  Beverly Voth

                  --

                  • 6. Re: Merge Field
                    Stephen Huston

                    To further limit the risk of future Paragraph/Carriage Returns within data fields, use the layout inspector to set both the Tab and the Return keys to Go to Next item in the tab order. That will stop users from adding returns within the fields.

                    • 7. Re: Merge Field
                      nella

                      I used individual lines for the merge text and clicked the sliding up and it looks perfect.

                       

                      Thank you all very much.