6 Replies Latest reply on Aug 20, 2014 1:28 PM by mlichtenberg

    Accessing Web Direct

    mlichtenberg

      Hello!

       

      I see that some folks in the Dev Forum have Web Direct operating with IE 11 (or any version of IE for that matter). Can anyone share the secret? When we try to connect all we get is "The web browser you are using is too old or not supported. Please use a supported web browser." Perhaps we are overlooking a setting? Your expertice would be greatly appreciated!

       

      Thanks

      Mark

        • 2. Re: Accessing Web Direct
          mlichtenberg

          Thanks for the reply. by changing the F12 details of my browser I can get the site to work. I am not sure that our users are going to know how to do this. Once we determine the 'emulation', how do I fix the WebDirect web site so that it can be published?

          • 3. Re: Accessing Web Direct
            johnnyb

            What is your project's URL like? IE will default to compatibility mode if you access a site by its IP address, a shortened host-only URL, or a URL on a .local or .private domain. For example, if you access your project at something like <https://project/> or <https://project.local>, it may be switching to compatibility mode. Could that be involved?

            1 of 1 people found this helpful
            • 4. Re: Accessing Web Direct
              mlichtenberg

              My original thought was that this may be a common issue with a simple answer. My team has been trying desperately to get FileMaker accepted as a viable solution by our organization. We are hoping that WebDirect could be the messenger that we are looking for.

               

              Please allow me to share some details about our environment. Perhaps someone will recognize the error of our ways and set us straight!

               

              We are using:

              FileMaker Server 13.04.0400

              Host is Windows Server 2008R2 standard, 2 CPU and 16 GB RAM

              By default the host uses IIS 7 to publish the website.

              Operating FileMaker Server is the only purpose of this server.

               

              We have tried

              Internet Explorer 9

              Internet Explorer 10

              Internet Explorer 11

              On Windows 7, Window 8, and Windows 8.1

               

              The issue is regardless of IE version or OS platform when trying to connect to http://SERVER/fmi/webd we get the same error message in the browser window, about half way down the webpage in a large truetype looking font: “The web browser you are using is too old or not supported. Please use a supported web browser.”

              • 5. Re: Accessing Web Direct
                johnnyb

                In all versions of IE, accessing the server by a URL like http://SERVER/fmi/webd will trigger compatibility mode. IE's compatibility mode disables the modern technologies that WebDirect requires. Those technologies being disabled is what causes the message you describe to appear.

                 

                What I'm suggesting — let me know if you try this and if it helps at all — is to use a fully-qualified domain name in your URL. Using just "SERVER" will trigger IE's voodoo. Using somethinglike "server.your-organization.com" instead will prevent IE from guessing that it needs to turn on compatibility mode based solely on the URL. It is not the only thing that will cause it, but it is at least one thing that will cause it.

                 

                So, by way of another example:

                 

                In our organization, all of our servers are addressable by an internal domain name ending in .com; let's call it johnnyb.com. This isn't a public domain, it's only internal to our company network. In our local DNS servers, the hostname "filemaker" resolves to the same internal IP address as "filemaker.johnnyb.com." So I can access WebDirect at <http://filemaker/fmi/webd> or at <http://filemaker.johnnyb.com/fmi/webd>. But when I use the first URL in IE, I get the message you describe. When I use the second URL in IE, it works as expected.

                 

                Now, your organization will need to have a little DNS infrastructure in place for this to work. You'll need to contact the administrator of your DNS server, and you'll need to get a hostname for your WebDirect server. And then, for people to access your solution, you'll need to distribute the URL with the fully-qualified domain name, which will be something like http://server.your-organization.something/fmi/webd… where, ideally, "your-organization.something" is your organization's internal domain name.

                 

                Having said all this of course, there are a lot of variables in this situation. The hostname issue is one I've dealt with personally, and so I feel comfortable sharing my experience with it. I hope it helps!

                • 6. Re: Accessing Web Direct
                  mlichtenberg

                  Okay johnnyb, you are the man! The actuall server name is of course not 'Server' but i got your point. We were no using the fully qualified name. When we did it works like magic!

                   

                  Many thanks, I hope some day to be able to return the favor!

                   

                  Mark