3 Replies Latest reply on Sep 8, 2014 5:56 AM by LyndsayHowarth

    VPN slows down when typing in 'developer' mode...

    johnbuckingham

      I have used various methods to connect to clients' machines to maintain their FileMaker systems. Over the last few months these connections are slowing to such an extent that they're almost unuseable.

       

      The method I used originally was using Draytek Vigor routers at both ends to create a LAN to LAN vpn then using Apple Remote Desktop to connect between machines - even this was prone to latency issues occasionally. When I upgraded from wire based adsl to 'fibre' (that's another story - a waste of time and money in this part of the world; down speed doubled to just 8Mb/s, up speed stayed at 500Kb/s and now I'm contracted for 18 months), the Draytek was replaced with a Netgear WNR2200 which can't even spell vpn. So, since that change, I've tried a machine to LAN vpn created using the Apple Network preferences and then either Apple Screen Sharing or Apple Remote Desktop. Or Splashtop either with or without the vpn running. In every case, the problem is the delay I frequently encounter while in 'developer' mode. The least badly affected of the methods is Splashtop, so I tend towards that most of the time. Also I use Network Radar to keep an eye on ping reponse to the remote site's external IP address from another machine on my network and the response seems not to vary, regardless of the state of the connection.

       

      When I run Activity Monitor on the remote Mac, usually the top three apps when sorted by CPU usage % are Splashtop Streamer & windowserver - both around 50% and then FileMaker Pro Advanced at around 10%. This situation obtains for 'user' activities like search, sort, navigate or data entry.

       

      But whilst programming FileMaker (e.g. define fields, or layouts, or add/edit scripts) pretty much whenever I type text, 'windowserver' application's cpu usage shoots up to around 100% and the FileMaker app 'takes a back seat' - often going inactive (i.e. red). And until the cpu activity settles down - usually taking 30 seconds or more - even if FileMaker is not 'hung', the screen is either completely unresponsive, or my keystrokes only appear on the remote screen at a rate one every ~2 seconds. During these periods, the screen may also be incredibly 'fuzzy' and trying to move items (i.e. windows, dialog boxes or layout elements) is pretty much impossible.

       

      The machine at the other end - the remote device - is a 2.53GHz Intel Core 2 Duo Mac mini with 4GB of DDR3 memory running OS X Mavericks. And the bandwidth at the far end is 18Mb/s down, 1Mb/s up.

       

      I would consider getting a fibre compatible Draytek to re-enable LAN to LAN vpn if there was a fighting chance it would help. But I'm loth to spend that sort of money until I have a better idea of what may be causing the issue.

       

      My isp (Zen) assures me they don't traffic shape. But then so does the isp for the remote end but in the same response they offer a priority service for more money which suggests that they do.

       

      Thanks for taking the time to read thus far: If you have any suggestions for what I could do to try to improve my experience, or to throw more light on the reasons behind this, they will be most gratefully received.

        • 1. Re: VPN slows down when typing in 'developer' mode...
          johnnyb

          Would you be able to test whether typing is slow or delayed while working directly at the remote machine? Could you drive over there one day to try it out, to take the VPN and remote desktop out of the equation?

           

          Things that come to mind with slow text editing include TextExpander, a deep subtitutions list in the Keyboard control panel, a corrupt spelling checker dictionary, an internationalization problem, or a fonts problem. All of these would tie up the WindowServer process while it struggles to handle your keyboard input.

           

          In any case, I would want to isolate the issue before spending too much time and effort on troubleshooting the network connection. It's difficult to imagine what about the VPN could possibly cause WindowServer any grief.

           

          You might want to run Disk First Aid and good ol' Repair Permissions while you're at it.

          1 of 1 people found this helpful
          • 2. Re: VPN slows down when typing in 'developer' mode...
            johnbuckingham

            Hey johnnyb

             

            Thanks for your response. I had already tried your suggestions: Nada. In addition, I also removed as many documents as possible from the desktop as I gather that windowserver treats desktop documents as being 'open' even when they're not, which can slow things down. The situation became unbearable over the last couple weeks - my co-worker and I were pretty much unable to work because of the speed of response. It saps your concentration and the creative juices stop flowing after a couple of hours.

             

            Then, I read this : http://www.tristanbettany.com/2013/06/17/slow-screen-sharing-in-osx-vnc-performance-issues/

             

            I got some 100 Ohm ±1% (0.6W) resistors, connected them as Tristan Bettany suggests, hooked it up et viola; we have two responsive Mac minis and we can both get on with the job in hand.

             

            This is an unbelievable situation. The Mac mini has become an incredibly useful machine to install at clients' sites, or generally run as a headless device on the network. And it seems that OS X 10.9 Mavericks renders it practically unuseable for this purpose. As things stand, we've only had these resistors in place for two days; so it is distinctly possible that it may be that the problem has receded for another reason; but, right now, I'd advise anyone with a headless Mac mini on OS X 10.9 Mavericks to install this modification (and not just over a vpn; the machine became more responsive from LAN access as well!)...

             

            Kind regards to all

            JB

            • 3. Re: VPN slows down when typing in 'developer' mode...
              LyndsayHowarth

              Interesting!

              I hadn't realised the problem existed.

              I have 4 headless MacMinis (one is 200km away) and whilst I do screenshare with/between them, I don't do it via VPN. I had been considering it though.

               

              Thanks for the 'heads-up'.

               

              - Lyndsay