AnsweredAssumed Answered

VPN slows down when typing in 'developer' mode...

Question asked by johnbuckingham on Aug 21, 2014
Latest reply on Sep 8, 2014 by LyndsayHowarth

I have used various methods to connect to clients' machines to maintain their FileMaker systems. Over the last few months these connections are slowing to such an extent that they're almost unuseable.

 

The method I used originally was using Draytek Vigor routers at both ends to create a LAN to LAN vpn then using Apple Remote Desktop to connect between machines - even this was prone to latency issues occasionally. When I upgraded from wire based adsl to 'fibre' (that's another story - a waste of time and money in this part of the world; down speed doubled to just 8Mb/s, up speed stayed at 500Kb/s and now I'm contracted for 18 months), the Draytek was replaced with a Netgear WNR2200 which can't even spell vpn. So, since that change, I've tried a machine to LAN vpn created using the Apple Network preferences and then either Apple Screen Sharing or Apple Remote Desktop. Or Splashtop either with or without the vpn running. In every case, the problem is the delay I frequently encounter while in 'developer' mode. The least badly affected of the methods is Splashtop, so I tend towards that most of the time. Also I use Network Radar to keep an eye on ping reponse to the remote site's external IP address from another machine on my network and the response seems not to vary, regardless of the state of the connection.

 

When I run Activity Monitor on the remote Mac, usually the top three apps when sorted by CPU usage % are Splashtop Streamer & windowserver - both around 50% and then FileMaker Pro Advanced at around 10%. This situation obtains for 'user' activities like search, sort, navigate or data entry.

 

But whilst programming FileMaker (e.g. define fields, or layouts, or add/edit scripts) pretty much whenever I type text, 'windowserver' application's cpu usage shoots up to around 100% and the FileMaker app 'takes a back seat' - often going inactive (i.e. red). And until the cpu activity settles down - usually taking 30 seconds or more - even if FileMaker is not 'hung', the screen is either completely unresponsive, or my keystrokes only appear on the remote screen at a rate one every ~2 seconds. During these periods, the screen may also be incredibly 'fuzzy' and trying to move items (i.e. windows, dialog boxes or layout elements) is pretty much impossible.

 

The machine at the other end - the remote device - is a 2.53GHz Intel Core 2 Duo Mac mini with 4GB of DDR3 memory running OS X Mavericks. And the bandwidth at the far end is 18Mb/s down, 1Mb/s up.

 

I would consider getting a fibre compatible Draytek to re-enable LAN to LAN vpn if there was a fighting chance it would help. But I'm loth to spend that sort of money until I have a better idea of what may be causing the issue.

 

My isp (Zen) assures me they don't traffic shape. But then so does the isp for the remote end but in the same response they offer a priority service for more money which suggests that they do.

 

Thanks for taking the time to read thus far: If you have any suggestions for what I could do to try to improve my experience, or to throw more light on the reasons behind this, they will be most gratefully received.

Outcomes