5 Replies Latest reply on Sep 24, 2014 9:33 PM by user19752

    FMS 13 Allows XML Read but not write

      We have a rather extensive solution built around FX.php and FileMaker 11 by my predecessor. I have begun exploring moving that over to FileMaker 13. I have everything updated as much as FX has been, including the change last year allowing it to fix the dreaded error 4.

       

      I have a windows server 2008 r2 server set up with FileMaker Server 13 set up as a single machine configuration with XML enabled.

       

      I can add a record in FileMaker and edit a record there as well.

       

      I have basic authentication enabled in IIS.

       

      I can access the xml stream in a browser and return a record or set of records using either fx.php or just an xml query in the address bar of a browser.

       

      If I try to run a query in either that writes to the database, any database, any layout, it comes back with an error 200.

       

      I have multiple accounts with full privileges that I have tried. I have multiple files I have tried. Some that are 11 files that were converted. Some that are brand new FMP13 files.

       

      I am sometimes getting an authentication dialog which won't take any set of credentials in the db and sometimes not.

       

      Has anyone run into something like this? At first I thought it was that the file or directory was marked as read only, but upon inspection, it was not and like I mentioned, I could do everthing right in FMP.

       

      I would prefer to be working in the FMP API but there are many man hours leveraged in this solution already, so my first move I would like to make is to filemaker 13 to take advantage of the improvements in the server.