12 Replies Latest reply on Nov 4, 2014 10:38 AM by intex

    Alias for database files not working in runtimes anymore ?!

    intex

      Hi at all,

       

      when building a runtime, the database file has to stay in the same folder as the runtime app and can´t be renamed. That´s the way it is, although

       

      a) people quite often like to rename files or want to change folders

      b) the system expects the app in the program folder and the user´s data either in the documents or the library folder

       

      On the other hand this way a FM runtime based app is simply portable for example via a USB stick - just copy the folder.

       

      Since years - as I can remember - we suggested customers, who didn´t want to have their data in the program folder nor their program in the documents folder, just to make an alias of the database file, i.e move the database file whereever you want, create an alias of it, move the alias back to the FM runtime app folder, cut off " alias" from the name and then you can use the runtime with the database sitting anywhere, even on network drives.

       

      I tested it for myself this morning again, after a customer told us, that this wouldn´t work for him. And now there is trouble, at least in OS X 10.10. Although the alias is working and has the name of the original database file, the runtime says "this in not the primary file or it is damaged". I then tested again on another machine with Mac OS X 10.8.5 and it worked as described. So in my eyes it has nothing to do with the runtime app itself, the database file or the FileMaker version (tried it with 12 and 13).

       

      Can anyone confirm ?

       

      So the question is: Did Apple change anything with aliases from 10.8 to 10.9 or 10.10 ? If yes, what did they change? And: Is there a way to get the alias working again like it did for years ?

       

      Thanks in advance

       

       

      Martin