5 Replies Latest reply on Nov 2, 2014 2:27 PM by keywords

    Zoom commits record?

    Extensitech

      I just noticed that zooming a window causes the record to be committed. Perhaps there's a perfectly good reason for this, but I've never noticed before.

       

      Can anyone else comment on whether this is expected behavior, and if so, why?

       

      I'm on Windows 7 and Windows 8.1, running FMPA 13.0v3.

       

      Chris Cain

      Extensitech

      ccain@extensitech.com

        • 1. Re: Zoom commits record?
          planteg

          Hi Chris,

           

          tried it on FMP 13.0.v3, same behavior. I also tried it on FMPA 12.0v4, and again the record is saved.

           

          Whenever a record has been changed and you click outsize a field, FM will try to commit the record. I say try because you can have a script set to OnRecordCommit that will cancel the commit.

           

          Looks like the standard behavior where FM make sure changes are committed.

          • 2. Re: Zoom commits record?
            Extensitech

            I understand that it's happening. Why would this be expected behavior, though? Plenty of other window actions don't commit the record, like resizing, refreshing, showing or hiding the status area...

             

            Why, when zooming the window, would FM need to "make sure changes are commited"? The user is clearly not leaving, or attempting to leave, the record.

             

            As for OnRecordCommit, that's actually how this came up. The user is on a new record, and I need them to enter certain data before the record gets committed and the script moves on. The client asked that the window be zoomed to a smaller size, so they could see things in the background window. I can't zoom the window without committing, and since ORC is preventing commit, the window won't zoom. I can certainly work around this (in fact, I already have), but I'm still awfully puzzled about why this particular action requires commit.

            • 3. Re: Zoom commits record?
              Stephen Huston

              My suspicion is that it was done because zooming IN might make the cursor go off-screen, and zooming OUT might make the active field small enough that it was hard to place or identify the cursor position. That would mean the best choice was to take the cursor out of the field, so no field was active, thus committing the record by default.

               

              Just my guess about the reason (assuming there was actually some reasoning involved), though I agree that a zoom shouldn't require a commit. Glad a workaround solves the problem for you.

              • 4. Re: Zoom commits record?
                jormond

                I've always wondered about that too Chris. I've come up with a variety of possible explanations, and none of them really explain why it has to happen. From a user or developer perspective, it's not really expected.

                • 5. Re: Zoom commits record?
                  keywords

                  Maybe someone from FMI, or at least with inside knowledge, might chime in and explain the reasoning.