12 Replies Latest reply on Nov 19, 2014 12:46 AM by rrrichie

    Does FileMaker Server ever work out of the box on a clean System

    rrrichie

      Just installed a fresh copy of Yosemite 10.10, Installed FileMaker Server 13 on it, but can't get the Web Publishing part to work.

       

      Stupid thing is the installer won't even run, cause FileMaker is not a certified developer by Apple (what the f*ck?*?!#?) (that was easily solved, but really what is that about...)

       

      Anyway, is it just me or is Apple sucking more and more as new OS versions come out. I'm starting to think Windows would be a better platform with less maintenance issues than Mac OS X.

       

      I keep getting the 404 or 403 on the Web Server test with de Deployment Assistant. I'm just so fed up with this shit, I want to write code not waste my time on stupid install issues on clean machines. (I can understand if you upgrade through many osses etc you have to solve issues, but come on this is fresh install, how hard can it be.)

       

      My boss is on my neck cause instead of FileMaker being a rapid development environment, my PHP buddies are developing a whole lot faster.

       

      I tried this combo

      sudo apachectl stop

      sudo /Library/FileMaker Server/HTTPServer/bin/httpdctl graceful

       

      Which changed the error from 404 to 403, but you get a lot of module errors from starting Apache, so I solved to by commenting out a whole load of modules, but then Apache complains it doesn't know the User command (really???). Anyway that required load a new module, which is not present on Mavericks... Pff and now I am fed up need coffee.