AnsweredAssumed Answered

FileMaker Server 13.0v5 update seems to kill the web server and SSL connection

Question asked by BenGraham on Dec 13, 2014
Latest reply on Dec 15, 2014 by psijmons

I recently purchased a new approved thawte 123 SSL that is on the approved FMS ssl list. So that I could follow the recomendations for security running the new v5 update. I am running a OSX Mavericks Mac mini server. I successfuly imported the SSL using the Certificate Import command line creating the serverCustom.pem from the serverRequest.pem and the serverKey.pem. I could see that all was running well on 13.0v4.

 

When I ran the update there was no connection to the server from WAN only the server admin panel via localhost:16001. Which shows the Web Server is not running, hence PHP is not enabled. I tried editing the depolyment, which gives this error trying to stare web server:

Test web server (http://127.0.0.1:80/fmi-test/test.xml): Connection refused

Test web server (https://127.0.0.1:443/fmi-test/test.xml): Connection refused

 

I stopped and started the server with the terminal command.

 

Still not working.

 

I then removed FMS , installeld 13.0v1 and got all working again and was able to test and have php working properly. All with the new SSL not the FMI SSL. Looking good.

I proceeded to 13.0v3 upddate. Tested all still okay.

Then 13.0v5 update and I am back where I started. I cannot even reach the domain of the server. So it is somehow killing the connection on ports 80 and 443 which I know it takes over, but it is just not going.

 

Does anyone have a solution or idea how to resolve this?

 

I do have the OS X server app running, but have Web Services Off. This has not been an issue since FMS 13 other than I did not have an approved SSL, so I had been using the FMI SSL up to now.

 

Cheers,

Ben

Outcomes