AnsweredAssumed Answered

FM13 server giving 404 error when accessing PHP or HTML

Question asked by mcarey on Feb 7, 2015
Latest reply on Feb 8, 2015 by lem_alpha

I have both a FM12 and FM13 server running on two similar hosts. Both are running Windows 2008 Server R2 standard.

I have a FileMaker DB and PHP site files on the FM12 server that run fine. I have copied the database and php site files over to the FM13 server and I get a 404 error when I try to access the files.  I can reach and open the DB on both servers fine with FIleMaker 13 client.

 

I noticed that the web configuration inside IIS is different on the two computers and I have attached a file with a screen shot of the two configurations .

 

(1) FileMaker 12 Server:

Their is the default Web site which is running. Within that site I have a folder called sites and the folder I am trying to reach DSP.

 

 

(2) FIleMaker 13 Server:

Shows two sites. Default Website and FMWebsite. I can only run one website at a time as they both are using port:80.

 

When I run the Default website I don't get the 404 error but the php files cannot talk to the database and I get 500 internal error message. I can reach a simple HTML file I created and placed in the root (inetpub/wwwroot). The FileMaker console test page does not run in this configuration. The FileMaker console shows that PHP and webdirect are not running

 

If I turn off the Default Website and run the FMWebsite I get the 404 errors and cannot even reach a simple HTML file I placed in the root (inetpub/wwwroot) . The FileMaker console test page runs fine in this configuration and says PHP and WebDirect are running.

 

Any help in how I can resolve this would be appreciated.  Thank you.

 

-Mac

Outcomes