4 Replies Latest reply on Feb 12, 2015 7:12 AM by BruceHerbach

    Layout Mode in, cm, pt?

    BruceHerbach

      When working with Layouts,  I prefer to use pt for location and size.  In FMPA 13.0v5 If I'm working on a local file,  I can set it to pt and it seems to stay for the session.  Once I close the file and then re-open it,  first time I go to layout mode,  in reverts to in (inches ).

       

      Is there a way to lock this setting so I get the preferred setting.  I don't remember this being an issue in earlier versions (12,11 etc )

       

      Thanks

        • 1. Re: Layout Mode in, cm, pt?
          mikebeargie

          Pretty sure it's locked into the file somehow, not the machine.

          It's not in any .plist preference files that I can tell.

          I'm on FMPA13.0v5 on mac.

           

          I created a database, test.fmp12, went into layout mode, it was set to inches.

          I set it to pt, returned to browse.

          closed and reopened file, still in pt.

          closed filemaker, reopened file, still in pt. (made sure activity monitor showed FMPA closed)

          rebooted computer, reopened file, still in pt.

           

          I'd be curious to see if you open this test file, would it be in PT or IN. I've attached the file here.

          • 2. Re: Layout Mode in, cm, pt?
            beverly

            locked into file BEFORE hosting perhaps? What about hosting this file, changing the "default" and see what happens when opening again.

             

            Yes, Mike's test file was in 'pt' when I opened (locally) in FMPA 13 or FMPA 12.

             

            beverly

            • 3. Re: Layout Mode in, cm, pt?
              Markus Schneider

              YEs, it's written into the file before hosting. One has to set the units on the local file, then upload again to the server.

              WHen changing thing like this in the local file, make sure to edit something that FileMaker has to 'write down' - some of the settings won't be changed otherwise

              • 4. Re: Layout Mode in, cm, pt?
                BruceHerbach

                Mike,

                 

                You gave me the key to solving this.  I had already tried changing this in a local copy then uploading.  After reading your e-mail,  I downloaded the file from FMS,  opened it locally, went into layout mode,  changed it to pt ( again ).  Then I moved a field so that there was something to save.  After putting the field back went back into browse mode and closed the file and FMPA.

                 

                When I opened it again,  layout mode came up in pt.  (Yea).  So the it seems it takes setting the way you want to see it (pt ) and making a change to the layout so that there is something for FileMaker to save.  Just changing the type of measurement was not enough to save the setting to the file.

                 

                I uploaded this copy of the file to my server and re-opened it and layout out mode came up as pt.  Problem solved.

                 

                Thanks very much.