4 Replies Latest reply on Feb 20, 2015 1:26 AM by AllegroDataSolutions

    Possible Import command bug in FMA13.0v5?

    AllegroDataSolutions

      Something I've never seen before in FileMaker has been happening since updating to FMA13.0v5. Just wondering if it's something to do with this particular file, or whether anyone else has seen this behavior:

       

      I imported all records from the last backup of the client's current build, which lives on their WAN host. I un-check the option to allow auto-entry of the key field with a serial number.

       

      Next, the client has asked me to import data for their new branches, which are slated to begin using the database with the new build. The data for the new branches has been stored as flat files, on Excel spreadsheets.

       

      So, I add a column to every sheet for a numeric, serial number field, which will be the primary key for each field in a row that I will be importing into the parent table AND the foreign key for the fields that I will import into related child tables. I fill the serial number column in Excel, beginning with the next serial number that would be auto-entered in the database, so that it does not duplicate existing numbers

       

      But, when I import from the spreadsheets, FileMaker overwrites the most recent records with the new data. If I import 1,139 records, the last 1,139 parent records disappear, the new records get their key field values, and the data from their child tables gets related to the new data.

       

      I tried this several times, and I get the same result: Importing from the previous build works; importing from the spreadsheets does not. Just to see if the file format was at fault, I tried importing the spreadsheets into NEW fmp12 files, assigning the serial number values there, then importing into the new build of their database. But I got the same result.

       

      When importing, I have been using the option to Add records only and leaving the option to auto-enter data un-checked. This is the way I have always done it when I have to do a lot of parsing of data from text files or spreadsheets (back to FMP 3.0!) and need to have complete control and keep track of exactly what I am doing. It was working for me, up to FMA13.0v4.

       

      I was finally able to import the spreadsheets by letting FileMaker auto enter the primary key field values in the parent table, then numbering the foreign keys in the spreadsheets for the related tables with that same range of numbers. But I am mystified as to why this should be happening now, and why it only affects the data contained in these spreadsheets. Obviously, I need to do more testing. But I wondered if anyone else had seen this and, if so, what conclusions were drawn. FileMaker bug? Corrupt spreadsheet data? Corrupt master build file? Any ideas?