5 Replies Latest reply on Apr 30, 2016 10:13 PM by jfletch

    Web Direct not working. SSL errors.

    bigtom

      Since updating to 13v4 I have had an issue that I have been ignoring a little bit. Nothing web based is working on the FMS even though it is all turned on. The test page will not even pull up, but Pro and Go clients can connect no problem.

       

      I get the feeling this is related to the SSL certificate. The server has been having an SSH authentication error since the update and I have had trouble with resetting the SSL certificate.

       

      I get an error that the '/usr/bin/fmsgetpasskey' does not exist as well as "sudo: fmsadmin: command not found".

       

      Any ideas? This all used to just work without an issue with the standard default FM certificate and now it seems I cannot even setup another certificate.

       

      Install is 13v4 on OSX 10.9.2.

        • 1. Re: Web Direct not working. SSL errors.
          bigtom

          Well looks like it is something messed up in the actual update process. I installed FMS with my Dev License on another machine and I was able to get everything working perfectly.

           

          Must be some problem with using the FMS updater vs removing completely removing and installing with the latest version. I do wish things would just work like they are supposed to.

          • 2. Re: Web Direct not working. SSL errors.
            bigtom

            So that was not the fix actually. Wiping the entire machine and starting over. Hope that works.

            • 3. Re: Web Direct not working. SSL errors.
              dkb

              Did the wipe and reinstall work? Seems rather draconian.

              • 4. Re: Web Direct not working. SSL errors.
                ramon

                We had exactly the same problem after installing the 14.0.4a Update. fmsadmin command and Webdirect didn't work. SSLPassPhraseDialog: file '/usr/bin/fmsgetpasskey' does not exist. On the machine on which I got this error, there was no /usr/local/bin folder neither a /usr/bin/fmsgetpasskey file.

                 

                Fortunately I have another machine on which the installation worked fine. So I copied the whole /usr/local/bin (contains the following links: fmsadmin, fmserver_helperd, fmserverd, fmsgetpasskey) folder of the working machine to the defect one.

                 

                Then I changed the following line in /Library/FileMaker\ Server/HTTPServer/conf/extra/httpd-ssl.conf

                 

                SSLPassPhraseDialog  exec:/usr/bin/fmsgetpasskey


                to

                 

                SSLPassPhraseDialog  exec:/usr/local/bin/fmsgetpasskey

                 

                Afterwards I started webdirect again using:

                 

                sudo /Library/Filemaker\ Server/HTTPServer/bin/httpdctl graceful

                 

                Webdirect now works like a charm.

                • 5. Re: Web Direct not working. SSL errors.
                  jfletch

                  dkb: "Did the wipe and reinstall work? Seems rather draconian."

                   

                  Is that why they call the engine "Draco?"