3 Replies Latest reply on Feb 24, 2015 11:40 AM by ch0c0halic

    Web Server Fails to Start [Port 443 not enabled]

    MicheleOlson

      A recent OS Security update to a FileMaker 13 Server MacPro machine running Mac OS X 10.8.5 (12F45) seems to have shut down port 443.

       

      Even though WPE is on, the Web Server does not enable. Choosing either PHP or XML option to enable them .. shows the option enable is selected, but the Web Server does not enable.

       

      NetStat testing on port 443 shows nothing. It is not open and no other program is using it. Other ports are also closed: 9090 and beyond.

       

      The server machine has been restarted three times [ideas from earlier posts on how to activate the port], but this does not enable it. In fact, even though Auto Start of both FMS and WPE is enabled, WPE does not auto start.

       

      I think this might have a java issue, but am not sure. Java is version 7 Update 71 (build 1.70_71-b14). We were using MirrorSync to sync a single db on a remote iPad, but this syncing is now disabled. When the MirrorSync jnlp is run, the screen cannot draw itself correctly, constantly flutters whenever an icon requires imaging. This fluttering also occurs in a Finder window whenever a preview of an icon is required.

       

      Remote login to the AdminConsole from another computer on the network is not possible, nor is uploading of FileMaker files. All other server aspects of server work as they should. Login to AdminConsole on the server is possible by entering localhost, not the IP address of the server.

       

      I appreciate suggestions on how to enable the web publishing engine and open port 443.

        • 1. Re: Web Server Fails to Start [Port 443 not enabled]
          danielfarnan

          Not sure if this will help, but I recently had issues with the Web Server that boiled down to apache not being started when the machine booted. If port 443 is not visible in netstat (and thus probably unused), check to see if the httpd process is running. If it is not, follow the instructions here: https://clickontyler.com/support/a/38/how-start-apache-automatically/

           

          Note that you might have to modify the https.conf file to enable SSL, but that is something I don't know how to do yet.

          • 2. Re: Web Server Fails to Start [Port 443 not enabled]
            MicheleOlson

            Daniel,

             

            Thanks for the suggestion. I checked and find the httpd process is running. The user is listed as _www. There are three httpd processes running: 24 user is root; 443 user is _www, 145 user is _www. All are Intel (64 bit).

             

            I don't know if any of this is a clue, but am passing it on in case it shows something to you or others.

             

            Thanks,

             

            Michele

            • 3. Re: Web Server Fails to Start [Port 443 not enabled]
              ch0c0halic

              Nope, those are not the FMS http processes.

               

              Could be you have the OS's web server running?

               

              In the Activity Monitor there should be approximately 7 "httpd" processes running under user "fmserver".

               

              Command to start the FMS httpd processes.

              fmsadmin start httpserver

               

              I suggest:

              1. Make sure the OS X Web Sharing is not running.

              2. Use the CLI to start the FMS httpd services. (Command above).

              3. Verify the Processes are launched with "fmserver" as the User.

               

               

               

              If that doesn't start them then use these two commands and then try to start them again.

               

              Stop then start the FMS HTTPD instances

               

              /Library/FileMaker\ Server/HTTPServer/bin/httpdctl stop

               

              then

               

              /Library/FileMaker\ Server/HTTPServer/bin/httpdctl start

               

              then

               

              fmsadmin start httpserver