AnsweredAssumed Answered

Creating a PDF - won't write to disk

Question asked by mrochie on Feb 26, 2015
Latest reply on Jan 11, 2017 by iceman7

I've searched (thoroughly, I think) on this problem but the answers I got back have turned out not to work - so I'm stumped.

 

I've two scripts that are used over and over again throughout the day by the sales staff, that have recently stopped performing reliably. They've been in place since forever, too (when pdf creation by script was introduced - that long - years and years and thousands of pdfs).

 

The problem is that both scripts - sometimes - for just these two users - will not write the PDF to disk, giving the user the old "Cannot write file, disk may be full, use another disk, blah blah" message.

 

The naming convention is simple, no crazy characters, just alpha characters and a timestamp. The user doesn't have a file open with same name, either.

 

The two users in question have plenty of disk space locally (where it's writing, in their documents folder). The scripts are running with full admin privileges. I've repaired permissions on their Macs, tried fresh install of FM 13.0v5, checked for adware/malware, tried redirecting the file from writing to their documents folder to a different directory on their macs, and to a server share that they have write privileges to. Nothing has helped.

 

They'll tool through the day happily sending quotes and invoices, then bang, it'll crop up again. Quitting and restarting FM is the only way to get it going again. The user can then return to the record and the script performs as written.

 

I've also installed Advanced on one of them, and followed the debugger to the failure at the creation line to no avail -

 

Script step: Save Records as PDF [Restore; No dialog; "$_pdfName" ; Records being browsed]

 

Users are both on Macs, both on 10.9.5, both FM 13.0v5. Files are being served by FMS 13.0v5. Suggestions are welcome and appreciated!

 

TIA,

 

Tony

Outcomes