4 Replies Latest reply on Dec 1, 2015 1:06 PM by lyle

    FMPA 13.0v5 + Lion + draw popover = hang?

    lyle

      I decided to investigate popovers to see if their use would make sense in my projects, so I tried to draw one in a layout. Nothing appeared as a drew it, but the dialog box did appear with the title to edit. Once I dismissed that, the layout would not close, and I never did see the popover button or popover window. The File menu was even greyed out so I could not quit FileMaker. So, I killed the process. Once I opened the database again, the popover button was visible and worked. I could then add controls to the window, etc. Subsequent attempts sometimes crashed FMPA instead of merely making it hang.

       

      Killing the program every time I want to add a popover seems counterproductive. Has anyone else seen this?

       

      Thanks in anticipation,

       

      --Lyle

       

      FileMaker Pro Advanced, 13.0v5

      Mac OS X 10.7.5 (Lion)

      MacBook Pro 293

        • 1. Re: FMPA 13.0v5 + Lion + draw popover = hang?
          psijmons

          Yes, I have seen something very similar happening on a file that was damaged in some qurious way, same configuration FMPA13 & 10.7

          When you create a brandnew fmp12 file, do you see similar behaviour? This showed me it was file related, not OS)

          Are you using plugins that may interfere?

          • 2. Re: FMPA 13.0v5 + Lion + draw popover = hang?
            lyle

            Thanks for your reply!

             

            I tried creating a new, blank database, and got similar (bad) results.

             

            I have no plugins installed, so no interference there.

            • 3. Re: FMPA 13.0v5 + Lion + draw popover = hang?
              psijmons

              Try a re-install of FMPA,

              no reason why it should not work on this configuration

              • 4. Re: FMPA 13.0v5 + Lion + draw popover = hang?
                lyle

                I upgraded to 13.0v9 and got the same problem.

                 

                I have, however, tried a few things, and have some possible pertinent information.

                 

                If I use the Insert menu, instead of the buttons, I experience no problems. That is what I suppose I'll do, until I figure out how to fix this, or upgrade to v.14.

                 

                If I use the field/control or button/popover buttons by quickly clicking on them, so as not to cause the pop-up menu to appear under the buttons, the default tools (text box and plain button) work and cause no issues.

                 

                Using the buttons to access the alternative tools, the outline of the objects are not drawn, but they are created. If I switch to browse mode and immediately close the database, then when I open the database again, the new objects are there, and work. I just have to switch to browse mode and close the database between layout mode sessions. Even that is not 100% safe; I had FMPA crash when all I did was select the color picker to change the layout body background color.