3 Replies Latest reply on Apr 23, 2015 3:10 AM by eduncle

    FM Server 12 Security Update (4/21/15) with outdated FM Go Clients?

    eduncle

      I read through the information for applying the security update for FM12 and 13 products that was just released but it doesn't specifically state whether or not clients that are NOT updated will still be able to connect to a server that HAS been updated.

       

      So my question is......

       

      We have an FMSA12 Server with SSL enabled and clients that connect using FMGo v12.0.x and FMGo v13.0.x clients.

       

      If we apply the FMS12 Security Update (released 4/21/15) to the server, will these clients still be able to connect without updating to FMGo v13.0.9 ?

       

      Regards,

       

      Ed

        • 1. Re: FM Server 12 Security Update (4/21/15) with outdated FM Go Clients?
          Mike_Mitchell

          Ed -

           

          I don't know how definitive this is (so take it with a grain of salt), but one of the hosting companies I use sent out an email indicating that non-updated clients will not be able to connect to an updated server (v12), and vice-versa. They'll both have to be updated.

           

          FWIW.

           

          Mike

           

          P.S. Not sure why you wouldn't go ahead and update Go 12 to Go 13. Is there something special about holding onto the older version?

          • 2. Re: FM Server 12 Security Update (4/21/15) with outdated FM Go Clients?
            eduncle

            Thanks for the reply, I might set up a test server to verify this before I hit the button on our production server.

             

            The reason we have not updated some clients to 13 is that they are using iPod Touch Gen 3 devices which only support iOS6 which in turn, only supports FMGo v12.  To make matters worse, these are actual clients buying in to a solution so forcing them to upgrade devices they bought just 2 - 3 years ago isn't something we want to do right now!

             

            If we are forced to adopt this Security patch on our FM12 server because FMGo v13.0.9 will not connect to un-patched servers, we will be in something of a catch-22 situation.

            • 3. Re: FM Server 12 Security Update (4/21/15) with outdated FM Go Clients?
              eduncle

              Following up on this, I performed a test installation of FMSA12.0.6.600 and then applied the 4/21/15 update and it would appear Mike's info was correct. 

               

              FileMaker Go Clients with a version < 13.0.9 are NOT able to connect to a FileMaker 12 Server which has the 4/21/15 Security patch applied if SSL is enabled.

               

              Also, FileMaker Go Clients v13.0.9 (or later presumably) are NOT able to connect to a FileMaker 12 Server WITHOUT the 4/21/15 Security patch applied if SSL is enabled.

               

              Regards,

               

              Ed