3 Replies Latest reply on May 11, 2015 10:44 PM by CyborgSam

    Adding a calc field causes Recovery to fail

    CyborgSam

      This database has been fine for years. I constantly check it using FMPA's Recovery and compare the before & after using FMDiff.

       

      It was OK immediately before adding a calc field. After that Recovery reports issues with the database (log at the bottom).

       

      This is 100% reproducible. Even a simple calc like ["abc" & "def"] causes the fail. FMPA sometimes crashes when closing Manage Database and sometimes when closing the file.

       

      All Mac environment with 10.6.8 Snow Leopard (don't ask...). I develop offline using FMPA 11, upload to FMS 11 serving FMP 11 users. All software updated.

       

      I installed FMPA 11 on a different 10.6.8 Mac, same problem. I tried cloning, same problem. I tried exporting data, cloning, compacting, and re-importing data. Same problem.

       

      I then tried compacting and then compacting the compacted copy. That worked! I can again add calc fields and have Recovery pass.

       

      I'm worried about what caused this and if there's still some lingering corruption that Recovery and FMDiff didn't find.

       

      1) Any idea what went wrong?

      2) Have you had similar issues?

      3) Do you think it's OK to continue using the database?

       

      TIA,

      Sam

       

      ----------------------------------

      Recovery.log issues:

      Page 12963 marked free but not in free list

      ERROR: Page 12961 contains duplicate data, dropping it

      Dropped page starts with data of type: table alias

      ----------------------------------