1 2 3 4 Previous Next 45 Replies Latest reply on Mar 21, 2017 9:59 AM by AllegroDataSolutions

    Launch Center Taking Forever to Display

    AllegroDataSolutions

      Launch Center seems to be taking forever to load. This happens every time I open FMA 14 and every time I click Open or Open Remote. Hiding everything now that can be hidden in the Launch Center, with no visible effect on the Launch Center. It takes much longer to open a file than in any previous version of FileMaker. I haven't yet found a way to speed up this "feature" or disable it. The only option seems to be the menu choice for Recent files. No luck speeding up a local connection. Any ideas?

        • 1. Re: Launch Center Taking Forever to Display
          mikebeargie

          What are the specifications of your hardware? It takes less than a second for my launch center to load.

          • 2. Re: Launch Center Taking Forever to Display
            AllegroDataSolutions

            More like 25 seconds, at best, for me. It sucks up all resources, even when it's the only app running, Can't even move the mouse, or ALT-TAB to another app. If I start the Task Manager, to see whether FMA 14 is not responding, it either loads after the Launch Center is finished, or makes FMA 14 hang and then opens. None of this happening with FMA 13.

             

            I think the problem may be that I created a favorite host, to be able to access a database that I built for one of my clients and am continuing to develop. Previous versions of FileMaker didn't seem to try to connect to a remote host until you clicked File-Open Remote and selected a favorite host. My guess is FMA14 is trying to connect with the remote host at startup, with the idea that if you have entered a favorite, you're going to be connecting to it all the time and logging on to the server would be your next step. Not a good thing for developers, as I have several more favorite remote hosts to add for clients that have projects in development at any given time.

             

            System Specs: Windows 7 (64-bit). 6 GB RAM.

            • 3. Re: Launch Center Taking Forever to Display
              silvermane

              I am also having this issue with Launch Center taking around 75 seconds to open.

              I am running a Macbook Pro Mid 2012 2.3 GHz Intel Core i7 processor with 16Gb RAM running OS X 10.10.3 (Yosemite)

              • 4. Re: Launch Center Taking Forever to Display
                AllegroDataSolutions

                Just out of curiosity, have you added any remote hosts to your favorites? Or did you try logging in to a remote host and now it's on your Recent file list?

                • 5. Re: Launch Center Taking Forever to Display
                  silvermane

                  I have a developer copy of Filemaker Server 12 on my internal network that I use for my FM Pro 12 development but that is all.

                  The local server shows up in the launch center but it doesn't show any of the hosted FM Pro 12 databases on that server

                  • 6. Re: Launch Center Taking Forever to Display
                    silvermane

                    Okay, time for an update.  I have now removed FM Server 12 from my development server (internal network) and installed FM Server 14.

                    The three FM Pro 12 databases on the old server were automatically ported across to FM Server 14.

                    I have both FM Pro Advanced 12 & 14 installed on my development machine (Macbook Pro Mid 2012 with 16Gb RAM).

                    The FM Pro 12 still connects quickly and without problems to the FM Server 14 remote databases.

                    However FM Pro 14 takes around 75 seconds to open the Launch Center and when it does, the icons for the three hosted databases flicker briefly and then disappear.  I am unable to connect to any remote hosted database using FM Pro 14 but can open local copies on my hard drive.

                    Any clues would be helpful.

                    • 7. Re: Launch Center Taking Forever to Display
                      jrenfrew

                      check that the favourite button is not selected on the top bar, as you will see no files if none of them are marked individually as favourites

                      • 8. Re: Launch Center Taking Forever to Display
                        Markus Schneider

                        or - when favorites are selected - one of them might be on a server that is not available at the moment

                        • 9. Re: Launch Center Taking Forever to Display
                          AllegroDataSolutions

                          I've been trying to remove the favorite hosts I have added, to see if having one or more favorites is the problem. Unfortunately, I haven't been able to find a command to delete these entries.

                          • 10. Re: Launch Center Taking Forever to Display
                            steveromig

                            Edward Rubeo wrote:

                             

                            I've been trying to remove the favorite hosts I have added, to see if having one or more favorites is the problem. Unfortunately, I haven't been able to find a command to delete these entries.

                             

                            To edit / manage your list of favorite hosts, click FILE > OPEN FAVORITES > MANAGE FAVORITES.  For here you can edit / delete the hosts you have marked as favorites.

                             

                            Steve Romig

                            FileMaker, Inc.

                            • 11. Re: Launch Center Taking Forever to Display
                              siplus

                              When you select "open remote" you land on the Launch Center - Hosts dialog. Your favourites have a star top left. Click on the star, it will go away. Click done. Next time the Fav ain't there anymore.

                              • 12. Re: Launch Center Taking Forever to Display
                                AllegroDataSolutions

                                Steve,

                                 

                                Thanks for pointing out where the delete button is. Weird that it isn't also in the Launch center, though. (The Edit and  "+" are there, but not a "-" button.)

                                 

                                After adding my second favorite for a remote host (different client, different file, different server), the launch center started taking even longer to load (almost 45 sec). This seemed to give credence to the idea that FMA14 was contacting and caching remote hosts on startup.

                                 

                                Unfortunately, when I removed the favorites for the remote hosts, the problem did not go away. Still 45 seconds to load. Then I noticed that the remote files were still on the Recent list, so I cleared that as well. Now I have no favorites, no recent files, and it still takes 45 seconds to load.

                                 

                                When FMA14 is loading, everything locks up. And I mean everything. I can't click the File Menu and open a recent or remote file from there, avoiding the launch center entirely. I can't even use the Recover command, if I want to recover a damaged file that a client has sent me. I can't use other Windows apps while it is loading. Even Windows Task Manager, about half the time.

                                 

                                I've been developing FileMaker solutions for about 23 years. I never had a client ask me for a launch center with icons for his files. I've never seen users open files any way but File-Open, File-Open Remote, or File-Open-Recent (usually using the keyboard shortcuts). In principal, I have no objection to features like the launch center, if somebody out there actually wants or needs it. But to lose access to the File menu while for three quarters of a minute while the damn thing loads -- and nearly as long every time they click "Open" after that -- is not something I look forward to doing (or explaining to my clients).

                                 

                                Thanks.

                                Ed

                                • 13. Re: Launch Center Taking Forever to Display
                                  steveromig

                                  Edward Rubeo wrote:

                                   

                                  Steve,

                                   

                                  Thanks for pointing out where the delete button is. Weird that it isn't also in the Launch center, though. (The Edit and  "+" are there, but not a "-" button.)

                                   

                                  Not arguing that.  Seems like a very reasonable request / ask.

                                   

                                  After adding my second favorite for a remote host (different client, different file, different server), the launch center started taking even longer to load (almost 45 sec). This seemed to give credence to the idea that FMA14 was contacting and caching remote hosts on startup.

                                   

                                  Unfortunately, when I removed the favorites for the remote hosts, the problem did not go away. Still 45 seconds to load. Then I noticed that the remote files were still on the Recent list, so I cleared that as well. Now I have no favorites, no recent files, and it still takes 45 seconds to load.

                                   

                                  When FMA14 is loading, everything locks up. And I mean everything. I can't click the File Menu and open a recent or remote file from there, avoiding the launch center entirely. I can't even use the Recover command, if I want to recover a damaged file that a client has sent me. I can't use other Windows apps while it is loading. Even Windows Task Manager, about half the time.

                                   

                                  I've been developing FileMaker solutions for about 23 years. I never had a client ask me for a launch center with icons for his files. I've never seen users open files any way but File-Open, File-Open Remote, or File-Open-Recent (usually using the keyboard shortcuts). In principal, I have no objection to features like the launch center, if somebody out there actually wants or needs it. But to lose access to the File menu while for three quarters of a minute while the damn thing loads -- and nearly as long every time they click "Open" after that -- is not something I look forward to doing (or explaining to my clients).

                                   

                                  Did I miss a rundown on your hardware?  I assume some flavor of Windows based on previous comments on the thread but didn't see much more beyond that.  Can you elaborate a bit more?

                                   

                                  Typically a delay in the launch of the application comes down to a couple of things...

                                   

                                  1. An incompatible plug-in getting in the way.
                                  2. One or more (corrupt) fonts causing a problem

                                   

                                  The first one is easy enough to track down and verify.  The font one, on Windows, is a little trickier but still do-able.  I'd rule out both of these as suspects.  The hardware you are using would be a third thing to check but being the system requirements for 13 and 14 are the same I suspect you are OK there.

                                   

                                  And just for clarification, this only happens on launch and not every time you need to access the Launch Center.  For example, you do not experience a delay if you perform a FILE > OPEN once FileMaker Pro 14 is up and running...right?

                                   

                                  Steve Romig

                                  FileMaker, Inc.

                                  • 14. Re: Launch Center Taking Forever to Display
                                    stephensexton

                                    If it helps at all, I have a similar issue and have noted the following:

                                     

                                    1. Clicking on an opener file located on my desktop (to open a file hosted by FMS14 on the same machine) opens the login window within a second, even if FMPA14 was not running before hand.  However, opening the launch centre via FILE > OPEN will consistently take 30-40 seconds the first time I attempt this.  Subsequent attempts to open the launch centre are instant until I quit FMPA14.

                                     

                                    2. Opening FMPA14 from the dock takes consistently 30-40 seconds to display the launch centre.  Subsequent attempts to open the launch centre are instant until I quit FMPA14.

                                     

                                    * Initial opening of a file from the launch centre via FileMaker Go 14 also appears to be taking a very long time.

                                     

                                    So it appears to be the first display of the launch centre that is associated with the lag in my case.  Not running any FileMaker plug-ins.  Previously had lots of favourite hosts, but have deleted most of these with no change.

                                     

                                    Specs:

                                    1. Late 2012, 27 inch 3.4GHz Intel Core i7 (fusion drive)

                                    2. 16GB RAM

                                    3. OS X 10.10.3

                                    1 2 3 4 Previous Next