AnsweredAssumed Answered

What to do when you've solved a bug but don't understand how/why

Question asked by smith7180 on May 22, 2015
Latest reply on May 25, 2015 by codeslave

Until this week I've been fortunate enough to only encounter one real bug in filemaker.  I reported it on the tech support forum.  TSGal replicated it, and I later got a notice that the bug had been resolved in FMP14.  I was quite happy with the process from beginning to end.

 

I've encountered another bug resulting in FMP14 crashing, and after a couple of days fooling around I've modified my script in such a way that it no longer triggers the crash.  However, unlike my previous case, I am unable to isolate the exact action that triggers the bug.  Furthermore I have no idea why my 'solution' works.  Unfortunately I cannot post the database (it's a client's).  So I wanted to very briefly outline my scenario here and see if anyone had any ideas with how I might proceed in either reporting or isolating the bug.

 

The set up is this:

  • I have a Pop-up.
  • It has a trigger on close that runs a script
  • It also has a 'done' button that runs the same script as the "on close" trigger

This is what happens in Filemaker Pro Advance 14:

  • If I press the 'done' button, the script runs just fine
  • If I mouse outside the pop up (causing it to close) the result varies:
    • If I click on any area of the layout that isn't a portal: everything works fine
    • If I click on an area of the layout this is a portal (even if the portal is empty) filemaker crashes every time.
  • If I run the script with the debugger on, I never get the crash no matter how I close the pop-up.
    • If instead I manually go line by line (disabling and re-enabling each step), the crash will sometimes happen.  I'm at a loss though as even by doing this I haven't been able to isolate the bug

In Filemaker 13, I never get a crash.  The fact that the bug never occurs in 14 unless if I have the debugger enabled gave me an idea:

  • I added a single step to the 95 step script: pause for 0.01 seconds.

 

This has completely resolved the bug for me. However, I would like to actually know what is going on for my own peace of mind and so that I may report the bug.  Does anyone have any advice on what steps I can take to accomplish this?

 

Thanks,

J

Outcomes