6 Replies Latest reply on May 29, 2015 6:51 AM by disabled_jackrodgers

    FileMaker 14 Searches loosing indexing?

    taylorsharpe

      I've now run into this twice this week in two totally different solutions on different services.  What happens is that FileMaker looses the ability to search a field.  Whatever I search on gives the same found set and it has nothing to do with what I searched on.  I was able to export and reimport the data and all was better after that.  But I can't seem to figure out why and how this happened. 

       

      I'm using a Mac Pro with OS X 10.10.3 development computer that has the first releases of FMS and FMPA 14.  One database was on this server and the other one was on another Mac Pro server in a server farm. 

       

      This most recent time it happened was just after running a script sending out about 100 emails via an email client.  The script is very simple and it is not even using a mail plugin.  I somehow doubt it has anything to do with emails though even though it was the email field that corrupted. 

       

      My first thought was to turn indexing off, save it, and then back on.  But that didn't work.  So I exported that table's data and reimported it and all was good then. 

       

      I just was wondering if anyone else saw this happen on a recently converted FM 14 solution?

        • 1. Re: FileMaker 14 Searches loosing indexing?
          Fred(CH)

          Taylor Sharpe a écrit:

           

          […] My first thought was to turn indexing off, save it, and then back on.  But that didn't work.  So I exported that table's data and reimported it and all was good then. […]

          Next time it occurs, you may try a Recover, using advanced options, and just check "copy block as it is" and "rebuild field indexes" instead of importing/exporting.

           

          Also you didn't mention if, after the fail, you tried from another computer ?

           

          And long shot ones :

          1. If possible, i would try to restart FMS Database service next time it occurs.
          2. Is there a chance other developers than you are accessing the database with a FMP 12 or 13 ? I remember i had problems when used a FMP 13 with a host running FMS 12, since the langage list have changed between the two version. When one chose language x, the other version seen it as language y.
          • 2. Re: FileMaker 14 Searches loosing indexing?
            gdurniak

            It's hard to believe this could be worse in 14

             

            It may also be scrambled Record ID's

             

            Did it show blanks,  or question marks,  or just the wrong found set ?

             

            If you still have the records in a backup copy,  it might pay to attach it to a bug report

             

            greg

             

            > Whatever I search on gives the same found set and it has nothing to do with what I searched on

             

            > My first thought was to turn indexing off, save it, and then back on.  But that didn't work.  So I exported that table's data and reimported it and all was good then

            • 3. Re: FileMaker 14 Searches loosing indexing?
              taylorsharpe

              It's hard to believe this could be worse in 14

              It may also be scrambled Record ID's

              Did it show blanks,  or question marks,  or just the wrong found set ?

              If you still have the records in a backup copy,  it might pay to attach it to a bug report

              greg

               

              I searched for a specific email using the "==" and it found 126 of 133 records matched the found set.  You can see all emails and that they were all different.  I tried a soft search using just the first part of the email before the @ and it gave the same result.  Then I tried any other search on email and it would always find 126 records.  And the omitted emails had emails in the field, but it was not obvious why they were omitted. 

               

              I closed the database on the server and reopened it and it still had the same problem.  I couldn't shut down the server since other databases needed to stay open.  But the export and reimport seems to have cleared things up.  It is just something I haven't seen in a really long time on old corrupted databases.  The problem on this database has no recurred since the reimport, but keeping an eye on it. 

              • 4. Re: FileMaker 14 Searches loosing indexing?
                taylorsharpe

                And long shot ones :

                1. If possible, i would try to restart FMS Database service next time it occurs.
                2. Is there a chance other developers than you are accessing the database with a FMP 12 or 13 ? I remember i had problems when used a FMP 13 with a host running FMS 12, since the langage list have changed between the two version. When one chose language x, the other version seen it as language y.

                 

                1)  The database server had other more important databases running I couldn't shut down.  But I stopped and started the database to no avail. 

                2)  I was the only one working on this database (development database no one else has access) and using FMPA 14 on Mac OS X 10.10.3.  So the language thing doesn't seem to be the problem

                 

                But thanks for the thoughts... these are the types of things to think through and try. 

                • 5. Re: FileMaker 14 Searches loosing indexing?
                  Stephen Huston

                  I ran into this a lot with FileMaker GO 13, but have not encountered it in Pro 13 or 14 (yet).

                  In GO, the find was scripted, and rerunning the script a second time always fixed the behavior, so I never got around to transferring the file from my iDevice back to a computer to rebuild the file index, but that would be my recommendation as well.

                  Have not (yet) seen the problem with GO 14.

                  • 6. Re: FileMaker 14 Searches loosing indexing?

                    I seem to recall a technique of creating a compressed copy of a file before opening it with a new version of FileMaker.

                     

                    Also the initial versions are always a bit buggy. I am fighting the bouncing script names and script steps issue where when I click on a line in the script list it will head to the bottom of the list or even dissapear. In the editor it moves upward. Waiting for the bug fix.