AnsweredAssumed Answered

FMS14 WebDirect showing no databases on split deployment

Question asked by robwoof on Jun 26, 2015
Latest reply on Jun 28, 2015 by robwoof

I have a two-machine deployment of FMS14 that is not showing any databases in the WebDirect homepage. If I edit the deployment to a single-machine, all expected files are visible and can be used. Where do I need to look to troubleshoot this? The admin console reports that the web server is running, that the Web Publishing Engine is running, and both show the worker machine's IP address, but the WebDirect homepage shows no files. If I try to connect to a file directly, it gives "Error. Database not available."

 

Both machines are Windows Server 2012R2. Both are virtual machines running on VMWare ESXi, and worked beautifully running FMS13. I uninstalled FMS13 and installed and updated FMS14 as per the instructions, but WebDirect is not playing. Single-machine works fine, but two-machine does not.

 

Both machines have custom SSL certificates from GoDaddy. In the browser, both report correct SSL connections with  certificate name match. FMP13 and 14 connect to the Master and show secure connections with the green padlock.

 

Master is dual core, 16GB RAM. Worker is 8 core, 30GB RAM.

 

While it was a single-machine deployment, I uninstalled FMS and all Java installations on the Worker and reinstalled and updated FMS14 to 14.0.2.226 (the Master was installed as 14.0.1.204 and updated to 14.0.2.226 as well).

 

One thing that has occurred as a possible issue is that the Master has two network connections - one for "normal" use, and one internal to the VM host hardware for use for data backups to a NAS we have on the host. FMS on the worked seems to prefer this IP address, not the "normal" one. Is there a way to force FMS to use a specific network connection and ignore the other?

 

I'm stumped, and tired. I would appreciate any pointers anyone can offer to troubleshoot and solve this issue.

Outcomes