2 Replies Latest reply on Oct 2, 2015 1:39 PM by beverly

    FMP12A worked fine with ODBC to MySQL but FMP14A won't

    rowland_carson

      For about 6 years I've been using the Actual ODBC drivers to connect FMP as a client to various MySQL databases, both on my local machine and on remote servers. Most recently I've been running FMP12A on a MacBook Pro with OS X 10.9.5.

       

      I've just bought the FMP14A upgrade and am in process of checking that my existing FMP files work OK with the new version of FileMaker. All the plain-vanilla FMP-only files seem to open and work perfectly in FMP14A just as in FMP12A, and all the scripts etc seem happy. However, I'm having problems getting any file working that acts as a client to a MySQL database.

       

      I wondered if the Actual Technologies driver needed to be updated, so I checked for a new version and paid $14.95 for an upgrade - but installing this did not change my symptoms at all.

       

      As a sanity check, I created a new system DSN using the ODBC Manager, then created a new FMP file and tried to use the new DSN to connect it to a MySQL database, and still the symptoms (see next para) are the same.

       

      I set up the data source from the "manage external data sources" menu and specify a user name & password (same as used in the ODBC Manager to set up the DSN). When I try to create a table occurrence on the relationship graph for the MySQL shadow table It asks again for the user name & password, I fill those in, and immediately the dialogue window re-appears with empty fields asking for the user name & password. I did try entering them repeatedly but gave up after the 3rd or 4th repetition as it seemed to be an infinite loop.

       

      The first MySQL-client file that I opened in FMP14A would not work when I opened it again in FMP12A either. I eventually got it functioning in FMP12A again after deleting the external data source and re-specifiying it. I then had to re-sync and also re-connect fields as they all came up <file missing>.

       

      I've also noticed that I am getting new messages on opening existing files in FMP12A such as asking for Keychain access and sometimes something about sharing files which I can't quite remember.

       

      I feel sure I must be doing something really elementary that is wrong, but can't see it. All suggestions welcome!

       

      in friendship

       

      Rowland

        • 1. Re: FMP12A worked fine with ODBC to MySQL but FMP14A won't
          rowland_carson

          Obviously I was doing something even more elementary that was wrong, such as trying "share with my community"! Mark's message illuminates a serious error in the human interface for this community system, but I'm glad to know he's doing something about it.

           

          Anyway, the answer to my original question was to wait a couple of weeks and check again for Actual Driver updates; when I download and installed these, everything worked again and I was happy (although worried that no-one in the Filemaker community cared enough about my problem to post any response!)

           

          in friendship

           

          Rowland

          • 2. Re: FMP12A worked fine with ODBC to MySQL but FMP14A won't
            beverly

            1. I just saw your post. Please don't leave the community.

             

            2. I would recommend clearing the keychain. And I would recommend contacting Actual for plugin support.

             

            3. I'm so happy you have it working!

             

            -- sent from myPhone --

            Beverly Voth

            --