8 Replies Latest reply on Jul 31, 2015 11:31 AM by Mike_Mitchell

    FM PRO Touch 13 v 14

    Jason_Farnsworth

      In using FileMaker 13 Pro on a touch device the list view worked with the touch scrolling, fast forward to Filemaker 14 Pro same database however the touch scrolling does not work.

       

      What changed? I have looked for a setting but have not found one.

       

      Jason

        • 1. Re: FM PRO Touch 13 v 14
          mikebeargie

          I know the dialog for vertical portal scrolling changed.

           

          Fundamentally scrolling on the layout has changed with the addition of the navigation header/footer parts.

           

          What happens if you change your header/footer parts to the navigation header/footer parts?

          • 2. Re: FM PRO Touch 13 v 14
            Jason_Farnsworth

            Mike,

             

            I have tried with the native db, I also created a layout using the new navigation headers and have yet to realize the touch scrolling. Additionally I have added headers and footers to test but have not had success with it.

             

            Thanks

            Jason

            • 3. Re: FM PRO Touch 13 v 14
              mikebeargie

              Are there any settings on your "touch device" that might need to be updated. I'm assuming you're using something like a surface, but I am not really familiar with those at all. Most non-iOS devices have random-at-best control over gesture behavior.

               

              Also, did you try tapping the layout to "activate" it before scrolling?

              • 4. Re: FM PRO Touch 13 v 14
                Jason_Farnsworth

                Mike,

                 

                Thank you for the reply,

                 

                Your assumption is correct it is a Surface Pro tablet. I have check all the settings on the surface and they seem to be correct in that if I run the FMP 13 it runs just fine, however exit 13 and load FMP 14 or for that matter FMPA 14 and I lose the touch functionality. Given that it tells me the setting are ok on the Surface as it work well in 13 just not 14.

                 

                I hate to use the word "Bug" but, do you think it could be a "Bug" in 14?

                 

                Jason

                • 5. Re: FM PRO Touch 13 v 14
                  mikebeargie

                  It’s a grey area, FMI has never said it supports the surface so it’s hard to say it’s a bug. Have you tried using a USB mouse to see if the scroll wheel works? What about a USB keyboard with page up/down and home/end?

                  • 6. Re: FM PRO Touch 13 v 14
                    Jason_Farnsworth

                    Mike,

                     

                    I hate grey areas! Have said that without them no envelops would ever be pushed and progress slows. Yes while using the mouse and keyboard it scrolls as expected.

                     

                    Jason

                    • 7. Re: FM PRO Touch 13 v 14
                      worldcloud

                      FileMaker has not built specific support for the Surface (nor should they). They have stated that they have support for Windows 8 touch devices. Assuming you are not playing with the pre-release version of Windows 10, that means that your Surface should have support from FMI.

                       

                      FMI even specifically states 'Windows 8" in their new touch function descriptions for FileMaker 14. <see below>

                       

                       

                      Get(TouchKeyboardState) – In FileMaker Go and Windows 8, returns 1 (true) if the touch keyboard is set to display automatically when needed; otherwise, returns 0 (false). See Get(TouchKeyboardState) function.

                       

                       

                      In pervious versions certain touch gestures worked, but did not have official support. I have a Yoga Pro 2, a Toshiba Convertible, a Surface RT, and a Surface Pro- in addition to my iPad Air and iPhone 6 Plus- so the era of fingerprints on my displays is in full force.

                       

                      I also run a Logitech Windows 8 trackpad which also supports gestures- and the control for gestures is very similar to my MacBook Pro 13 Retina; however, the risk in 'custom' gestures is that if you develop for others it's hard to know if they will utilize the same 'non-standard' gestures.

                       

                      In FileMaker, I typically stick with the standard support...

                      • 8. Re: FM PRO Touch 13 v 14
                        Mike_Mitchell

                        I do know that we have some tablet PC devices here that worked fine under version 11, but the scrolling using a swipe gesture stopped working when upgraded to 12. FMI acknowledged, in that case, that it was a driver incompatibility with that particular tablet device. Don't know if it's something similar; maybe the way the Pro client captures gesture messages from the OS has changed?