4 Replies Latest reply on Aug 20, 2015 12:20 PM by Kesavan

    Value list based script not working

    Kesavan

      I am trying to extract evaluation grades for faculty from feedback from trainees. This is a FileMaker file with about 180 records for about 15 faculty. The following script worked very well in FileMaker Pro 11. However, in 13 it does not. Specifically, when searching for  individual records of a given faculty member based on a variable, it does not insert the variable into the search field. SetField option is not available in the script menus and insert calculated result using the variable as insert does not work, either. Also, it is really difficlut to export records into a specified folder, be it on the desktop or in the folder where the main file rests.

      Since the file was created in FMP13, there is no way to enable FMP11. I am not clear why this is not working in 13.

        • 1. Re: Value list based script not working
          Extensitech

          Options:

           

          Instead of enter find mode, set field, perform find, just do perform find and use $item as your search value.

          or

          Set field should definitely work in this case. You have it commented, but you say it's "not available"?

           

          A possible issue may be that insert calculated result requires the field to be on the current layout. Could that be your issue?

           

          Sorry if I'm stabbing in the dark a bit. I definitely use these methods, though, so I'm not sure I understand what's happening in your case.

           

          As to the specified folder, you say that it's "really difficult". In what sense?

           

          Chris Cain

          Extensitech

          • 2. Re: Value list based script not working
            user19752

            Additions, have you checked the $List value or value list name in the function?

            I also couldn't find any problem in script, "Set Field" should work better than "Insert...".

            • 3. Re: Value list based script not working
              Kesavan

              Thank you. I did 2 things that helped. One, I closed and reopened the FM13 Advanced. Now I find Set Field avaialble as an option in the script menu options. However, I still continued with Insert Calculated result. Second, in the ValueListItems (Get(FileName ) I added &".fp3"; before "Attending" & ".fp13"  ; "Attending" ) It worked right away.

              • 4. Re: Value list based script not working
                Kesavan

                After closing reopening the FM13 Advanced, Set Fieldoption became available in the scripts Meneu. Hiwever, I still used the Insert Calculated result, with $item. It is working. Problem resolved.