4 Replies Latest reply on Mar 28, 2011 3:27 PM by KenBublitz

    "Allow this value?"

    KenBublitz

      Title

      "Allow this value?"

      Post

      Part of my data base is a field "service provided", which has a list of services I provide with check boxes. I often have to make small additions/notes to items on the list using the "other" option in the list. When I do so, I've always get this prompt:

      “service provided” is defined to contain only specific values. Allow this value?

      In the past I just clicked yes, and that was it. But since I upgraded to FM Pro 11, after clicking yes, I get an upside down mirror image of the services provided value list added to the bottom of the layout (this is in browse mode). If i click on edit layout, its gone, and when I exit edit layout its gone. Not a big deal, more annoying than anything. But why is it happening?

      Thanks.

        • 1. Re: "Allow this value?"
          philmodjunk

          That's a weird one. You might want to run a recover on your file to make sure it isn't damaged. The message you are seeing is controlled by a validation option you can disable if you do not want it to appear at all. I think you've specified that values in your field can only be a value from the value list and that trips the validation message you are seeing when you select an "other" value.

          • 2. Re: "Allow this value?"
            KenBublitz

            Thanks Phil. I tried the recovery method on a file from years ago as a test. FM created a recovered version, but the result was the same. So how do I go about disabling the validation option. i should have added that I have not yet had time to create new databases using FM 11, just had FM convert files in FM 5 I had on previous computer. This seems to be the only oddity resulting from the conversions.  

            • 3. Re: "Allow this value?"
              philmodjunk

              I've converted a lot of 5.5 files to 10 and now use them with 11 here, but never saw that one. I'd check to see if this is a layout specific issue by creating anew blank layout and then putting a new copy of the field on the layout to see if you get the same behavior.

              To turn off the validation test, Open manage | Database | Fields, find the field definition for this field and double click it to open the field options dialog. Click the validation tab and see what validation rules have been specified. I predict you'll see that the "member of value list" validation rule has been selected. Clear that check box and this dialog should no longer appear.

              • 4. Re: "Allow this value?"
                KenBublitz

                Thank you, Phil, your prediction was spot on!