14 Replies Latest reply on Jun 10, 2009 2:38 PM by dxlnt1

    "File not found"

    dss

      Title

      "File not found"

      Post

      The problem I have with File maker pro 8.5 V2, which I am running on MAC osx 10.5.4 is -

      I have a database and couple of files in that. I have files such as Main, Contact, Current, Student etc...

      I open all those files in the sequence mentioned as it pulls info from the MAIN file.

      But when I am opening the current file it shows " Main student could not be opened (file not found)".

      Even when I am trying to go into find mode and search for some thing, a dialog box opens up saying it cannot fine a file(file not found). 

      I am not sure why this problem comes. I have tried reinstalling, updating filemaker pro.

        

      What will be the possible solution for this.

       

      Thanks 

      DSS  

        • 1. Re: "File not found"
          dss
             Any help would be appreciated.
          • 2. Re: "File not found"
            philmodjunk
              

            Filemaker stores filepaths that record how it opens a particular file when something in the current file requires it to reference an external file. You get the errror message you report when your file uses one of these "stored paths" to open a file that is no longer there. Renaming or moving a file is usually the culprit.

             

            I made the Jump from 5.5 to 10 so I don't have your version. In 10, You can select Manage | External Data Sources to see references have been stored. If you have that feature, you can use it to review and update your file references and this should fix your problem in most cases.

            • 3. Re: "File not found"
              dss
                

              I don't have manage option in 8.5

               

              any oter way to fix this issue?

               

              Thanks for your effort Phil.

               

               

              • 4. Re: "File not found"
                philmodjunk
                  

                This didn't always work for me in 5.5 but it's worth a try if you haven't done this already:

                 

                OPen the file with a full access password directly (not over the network). WHen you get the error message, you should also get an open file dialog box where you can find the missing file. Navigate to your missing file and open it. Now close, re-open and test your file to see if the problem is fixed.

                 

                Otherwise you get to play detective.

                 

                Something in Current is triggering a reference to Main. It could be you have a field or portal on your current file's layout that refers to Main. It might be a script. You might have a calculation field that refers to a related field in main that is displayed on your  layout. It could even be a value list that has been used to format one of your fields. Once you've found the culprit, you have to "reconnect" it to the main file in its current location. The exact steps will vary with the type of reference involved. In most cases, you simply have to repeat the steps used to select the main file that were used originally (even if it "looks" correct) to select an item in Main.

                • 5. Re: "File not found"
                  dss
                    

                  I tried playing detective...

                   

                  and

                   

                  figured out....

                  thanks a lot Phil. 

                  • 6. Re: "File not found"
                    dxlnt1
                       I have the same problem. I am runnig FM Pro advanced. I had to back up all data from a crashed hard drive. New location on new drive, filemaker files do not open. Keep getting file not found error. But I can open old file from old location on damaged hard drive. I tried to recover file but still get error, file not found. HELP!
                    • 7. Re: "File not found"
                      philmodjunk
                        

                      As I suggested earlier in the thread, Use Manage | External data sources to examine and modify your file references. If any of your scripts use Import Records, you will need to open and update those scripts individually.

                       

                      Or

                       

                      Rename the folders on your new location to exactly recreate what you have on your "damaged" location and place each file in exactly the same folder as you had in the original set up.

                      • 8. Re: "File not found"
                        dxlnt1
                           I am unable to perform that step as I cannot open the file. Also, some of the files are flat files. So there are no scripts, links or other external scripts running. It appears some kind of permissions issue but I compared files side by and identical in every way. I copy entire folder and individual files to new location and still get file not found. Even using the file open command returns same error!
                        • 9. Re: "File not found"
                          philmodjunk
                            
                          "I am unable to perform that step as I cannot open the file."
                          Why not? Even when you get this error message you can either locate a copy of the missing file and open it or click cancel to continue the process of opening the file. Once you've got it open, you can use Manage | External Data Sources to diagnose why you're getting the error messages.
                          .
                          "Also, some of the files are flat files. So there are no scripts, links or other external scripts running."
                          Filemaker will attempt to locate any referenced external file if there is a reference to the external file in the current layout. That reference could be due to:
                          1. There are one or more fields from the file displayed on the layout--either in a portal or separately.
                          2. There is a value list format on a field where the values are drawn from a field in the external file.
                          3. A calculation field displayed on the layout contains a reference to a field in the external file.
                          4. A script is running that refers to some part of the external file.
                          The "File not found" error message simply tells you that filemaker is attempting to locate a file to open and it's either not where it was expected or its name was changed. I suspect that a reason from items 1 - 3 above explain why you're getting these error messages.
                          Note also that one file 1 opens file 2, references in file 2 may require that filemaker open additional files or even try to find file 1 and fail if file 1 is differently named or located.
                          It's also possible that your file is damaged. You may need to recover copies of the files and test them. If the recovered files work, replace them with undamaged back up copies.
                          • 10. Re: "File not found"
                            dxlnt1
                               I agree with your observation. If I map to the file to open, I get error. So only dialog box is ok, and FMP stops. Click on file in new location, same message. Go to old file from damage drive, which incedentally has been repaired but I now use new HD, file opens no problem. I know it is very simple but cant figure it out. Again, flat files that I have are of 10 fields, no references, no external links, no portals, no reference. There may be value lists though. But I cannot get file open. Copying file to new location, rename, save as, none of these work. Could there be a permissions problem on new drive or with filemaker app?
                            • 11. Re: "File not found"
                              philmodjunk
                                

                              I still don't see in your post a reason as to why you can't get the file open.

                               

                              Open the file.

                               

                              1. You get "file not found" and a dialog to find and open the file.
                              2. Click cancel.
                              3. Repeat steps 1 and 2 until you get the file open. If there's a script trying to open files it can't find, then you'll get a message asking if you want to continue or cancel the script, cancel it.

                              Now you have the file open. Check your references and see what's missing. You may get lucky and see "missing" right in the layout that you can investigate.

                               

                              There are references, probably relationships, linking your main file to the missing ones. This information is all in your main file, not the missing files. They can be as flat as flat can be and still be missing when you main file is trying to open them.

                              To check for value list references, Open Manage | Value Lists in your main file. You'll probably see some "file missing" messages if any of them are to blame.

                              • 12. Re: "File not found"
                                dxlnt1
                                   the dialog is from filemaker file/open menu. And you are right, no reason why the file should not open. That is my dilemna! I switched startup disc and tried to open file in new location. I get same error. File not found. File in old location still opens no problem.
                                • 13. Re: "File not found"
                                  philmodjunk
                                    

                                  "the dialog is from filemaker file/open menu."

                                  That's exactly what I am describing. When filemaker attempts to open an external file, and fails to find it, it uses the open file dialog to enable you to find and open the missing file. You should see that you have two options: Open and Cancel. If you can find the file, you should be able to select it and click open. If you can't, you can click cancel and Filemaker will proceed without opening the missing file.

                                   

                                  I may be missing something here.

                                   

                                  My apologies if I sound repetitive, but what exactly happens when you dismiss the dialog by clicking "cancel"? Do you get your first file to open or not? If not, what does happen?

                                   

                                  • 14. Re: "File not found"
                                    dxlnt1
                                       That's ok because maybe I am not being clear either. One thing I found this morning was from my laptop, I am network in to desktop. The laptop shows an additional user folder. All of the files or rather this folder appears to be an exact duplicate of my home folder, i.e. the new location. But when checking accounts in system prefs, no such user exists. So now, if there is a ghost user folder the system is writing to or reading from, how do I consolidate these and delete the unsused one. Oh, the ghost foldr acts like a RAID partition but I never set up RAID! HELP? I am really lost now! Thanks for your help and input!