0 Replies Latest reply on Oct 21, 2011 9:48 AM by Chia-PohTai

    "File not found" error in "Send Event" action

    Chia-PohTai

      Title

      "File not found" error in "Send Event" action

      Post

      I am trying to run a UNIX script as part of a FileMaker Pro 11 (FMP) script in my database - export some records, process the records using the UNIX script then import the result into my FileMaker database.

      In my FMP script, I used the "Send Event" action to open a "document," the UNIX script, using Terminal as the Target Application.  But every time I ran the FMP script, I got "file not found" error.  The nFMP asked if I wanted to continue or not, which I clicked the Cancel button.

      I also tried using an Apple Automator workflow (that incorporating the UNIX script execution) as the "document" in "Send Event" with Automator as the target application.  But the result was the same, i.e. I got the "file not found error."

      The only time I didn't get the "file not found" error was when I made the Automator workflow into an application.  But then my UNIX script didn't get run - it didn't seem FMP recognize the Automator workflow application as a 'real' application.

      Screen shots (using Automator workflow document) are attached.  I also tried various file path alternatives with no luck.

      Any suggestion would be helpful?

       

      Thanks in advance... tai

      FMP-screen-shots.jpg