4 Replies Latest reply on Jan 31, 2010 8:15 PM by twelfthnite

    "Invoice.pdf" could not be created on this disk....

    dosborne_1

      Title

      "Invoice.pdf" could not be created on this disk....

      Post

      This is driving me absolutely insane. I've been using this database for almost 4 years now with a script that creates a pdf file and attaches it to an email.

       

      Well last night I decided to re-install OSX and everything associated with it and now I get this error. If I try to change this location, FileMaker will unexpected shut down.

       

      Here's what I've tried so far:

      Recreated the script step by step to find the problem - it's definitely the Save as PDF step

      Thrown Preferences away and restart - no fix

      I don't have IWP on

      All updated 9.0.3

       

      I even down loaded V. 10 and tried - no luck.

       

      This is the same computer I used this app on 2 days ago flawlessly, any ideas??????

        • 1. Re: "Invoice.pdf" could not be created on this disk....
          TSGal

          dosborne:

           

          Thank you for your post.

           

          If this occurring during the Save as PDF step, and no PDF file is created, it could be the creation of the PDF that is causing the problem.  Rename the AdobeFnt08.lst file and have Adobe create a new one.  On Mac OS X, this file is located at:

           

          Home -> Library -> Application Support -> Adobe -> TypeSpt -> AdobeFnt08.lst

           

          Rename it to "ORIGAdboveFnt08.lst".

           

          Try Save As PDF again.  If you crash now, see if a PDF file is created, and also see if there is an error message.

           

          TSGal

          FileMaker, Inc. 

           

           

          • 2. Re: "Invoice.pdf" could not be created on this disk....
            gregl
              

            You reinstalled Mac OS X, so maybe permissions for various things were reset/changed?

             

            Can you save any other type of file to the same directory with no problem?

             

            You mentioned that FileMaker unexpectedly shut down when you try to change the location... does that mean FileMaker immediately shut down (no crash alert, no crash log) when you tried to specify a new destination file for the Save Records as PDF script step using the file dialog, or when the script step was executed?

            • 3. Re: "Invoice.pdf" could not be created on this disk....
              dosborne_1
                

              I forgot to list in my "things I've tried" above that I used Disk Warrior to repair permissions and rebuild directory with no luck.

               

              As impatient as I am, I did a fresh install of everything again this morning, but loaded things in a different order and all is working flawlessly. I would love to find out if the Adobe suggestion listed above would have solved the problem, because I believe that it probably had something to do with it.

               

              During my first re-install, I installed Adobe CS4 first which includes Adobe Acrobat Pro, then FileMaker. I then tried to update FileMaker to 9.0.3, but used the wrong updater (I accidentaly used the SSL).

               

              Those were the only differences in my install. On a side note, when I install Adobe CS4 and then open a browser and try to hit a website with a Flash Audio Player, I get errors until Flash Player is the re-installed. So I have a feeling Adobe's installer is the culprit.

               

              Thanks for the suggestions, hopefully this will help out myself or others in the future.

              • 4. Re: "Invoice.pdf" could not be created on this disk....
                twelfthnite
                  

                I have searched every place I could find about creating pdfs.  I upgraded from 9 to 10 and Leopard to Snow Leopard.  The script for "Save Records as pdf" no longer works.  Worked great with 8.5 and 9, but I get the message "cannot create on this disk" I have removed prefs and Adobe Acrobat.  The funny thing is that it worked once and I hadn't changed the script.  Thanks in advance for your help.