8 Replies Latest reply on Jan 3, 2014 9:57 AM by johnhorner

    Active Field Hides Objects Above

    johnhorner

      Title

      Active Field Hides Objects Above

      Post

           I am having a small problem with a field that contains objects that are placed on top of it. When I click into the field, these objects disappear (or go to the background, objects that are larger than the field will still peak out around the edges of the field). However, I want these objects to persist on top of the field. Is this possible to do or does the field always override it's layered position and move to the foreground? please advise.  thanks!

        • 1. Re: Active Field Hides Objects Above
          philmodjunk

               Nit picking detail: The field does NOT contain these objects--that's why you have a problem here.

               As you have found, a field will pop to the front and obscure layout objects placed in front of it so long as the field has the focus (the cursor is in the field). But why place layout objects in front of your field? Why not re-size the field so that it is not "behind" the layout objects. You may want to make the field transparent and without borders and place it inside a rectangle with the same appearance settings as your field. The rectangle can then be behind your layout objects while your invisible field is sized and positioned just below or above the layout objects so that editing data in your field no longer hides these layout objects.

          • 2. Re: Active Field Hides Objects Above
            johnhorner

                 hey phil... thanks for the reply. the only reason i was trying to avoid placing the field on top of another object was to use as few objects as possible. i did try your method but then i experienced a different problem. if i give the field no fill ("none") so that i can see the objects placed above it, then when i click into the field, it turns a dark almost black color that matches the background even though there is an intervening white object, so the fill needs to be solid (unless there is a checkbox or preference somewhere to control this)? what i ended up having to do was place a smaller version of the field inside a larger background object and make both of them solid white fill. i have attached images below (ideal appearance, the problem with the transparent field, and the workaround solution). Please let me know if you have any other thoughts. Thanks again!

            • 3. Re: Active Field Hides Objects Above
              philmodjunk

                   With FileMaker 12 and 13, you can specify the fill color when the field has the focus. I'd experiment with those settings to see if that's a simpler approach to getting what you want to work. If you need help with the details of how to do that, let me know which version you are using as this part of the inspector is different in FileMaker 13.

              • 4. Re: Active Field Hides Objects Above
                johnhorner

                     boy, you're quick! i am in fm13 and had specified the "in focus" background to "none". so it looks normal until you click into the field, and then it seems to become transparent all the way down to the color of the body part behind it which is a very dark gray (middle image in screenshots above). so for example, if i make the body part red, the transparency of the field when it is active shows all the way through the white rounded rectangle beneath it to the body part fill... strange? or am i doing something wrong?

                • 5. Re: Active Field Hides Objects Above
                  philmodjunk

                       I am suggesting that you not specify an Transparent "In focus" fill color but that you specify a Fill color for the In focus state that matches the object immediately behind it. This would be a solid white from what I see in your latest screen shot.

                  • 6. Re: Active Field Hides Objects Above
                    johnhorner

                         oh, right... well, that's what i did for the "workaround" solution, but since the actual field is smaller than the object sitting behind it, i can't use certain style attributes (like putting a bright line around the field to show it is active and have it encompass the whole "field grouping" (i.e. the field itself, the object behind the field, and the icons/buttons on top of the object that sits behind the field) as i would like to do. other fields on the same layout have this behavior so i am trying to be consistent. below is an image of the default style of an in focus field. perhaps i can set up conditional formatting on the object behind the field. i was just hoping there was a way to accomplish this without the additional object and need for conditional formatting, but it seems that that is not possible in this instance (i.e. just with field style and formatting options).

                         it does seem a little strange that the lack of fill affects every object below it such that the body part color reads through. you would think it just affects the object it is on. And even more odd that the lack of fill in the default state does not affect the objects below it. Only the in focus state has this behavior. oh well... thanks!

                          

                          

                    • 7. Re: Active Field Hides Objects Above
                      philmodjunk

                           Transparent fields have functioned that way long before we had themes. In many older layouts, this method was used to help show which field is current and editable--though not with a black body, of course. We'd also sometimes control the "show through" color by using a colored rectangle sized to cover the entire body of the layout--which would be one way to get a black background without also getting a "show through" that's black.

                           Ultimately, I don't think you are going to be able to get the exact result that you want here.

                      • 8. Re: Active Field Hides Objects Above
                        johnhorner

                             well, this is embarrassing to admit, but i only discovered recently that i was able to apply formatting the layout parts themselves (hence my unfamiliarity with their expected behavior)! thanks for the new (old!) technique, it would have been a long time until it occurred to me to use a color on the body part AND a background rectangle with a different fill!