2 Replies Latest reply on Oct 23, 2010 10:08 AM by Gasser

    Add Table to Existing Database

    Gasser

      Title

      Add Table to Existing Database

      Post

      Hi All,

      Similar to Cathedog04 (message of 15 March) I am new to Filemaker and have a number of tables I have transferred into the Filemaker format. Try as I may, I cannot add them as Secondary Tables to a database I have begun with one of the tables as the Master Table. The Add Table icon at the bottom left of the Define Database dialog box does add them in the Relationship Graph, but they do not appear under the Tables or Fields sections of the Manage Database window. What should I do? Many thanks, Richie

        • 1. Re: Add Table to Existing Database
          FentonJones

          The "Tables" are the list of the tables that are actually IN the file. The Relationship Graph on the other hand can have instances from ANY FileMaker file that you can point to. The Table Occurrences (TO) on the graph are more like "aliases" to the tables; the files/tables themselves do not need to actually be IN the current file itself; it's an abstraction.

          It sounds to me as if you created multiple files, of one table each, when you converted some other kind of files to FileMaker format.

          If you want them to actually BE IN one file, you need to Import each other file's tables, one at a time, using the option to "Create New Table", as the Target of the Import. This option is at the bottom of the drop-down Target list.

          Then they will appear in the Tables, and can be renamed, and put onto the Relationship Graph. Or, if you've already put TOs targeting the external tables on the graph, you can just repoint them to the now internal tables. Likely the fields will still line up, but you should check that.

          • 2. Re: Add Table to Existing Database
            Gasser

            Excellent explanation. None of the books, not the File Maker Support tools, and not the File Maker Help file gave me a clue.  Now I can go forward. Thanks so much!