AnsweredAssumed Answered

Adding portal row doesn't work although creation is allowed

Question asked by StefanSaeys on Sep 1, 2014
Latest reply on Sep 4, 2014 by philmodjunk

Title

Adding portal row doesn't work although creation is allowed

Post

It seems that I have an issue with FM13 and portals.

 
I’ve got three tables in a many-to-many relationship: <companies>, join table <companies_contacts> and <contacts>.
The tables are allowed to create and delete records in both ways.
 
I’ve added a portal in layout companies to join table <companies_contacts> and placed the fields contacts::FirstName and contacts::LastName from the table <contacts>
In my first version this worked as expected: if I put contents in the field on the second line, a new record in <contacts> was created.
 
But when I tried creating this again in the “master" database it doesn’t work.
I can’t find any differences between the database that works and the new one that doesn’t. I’ve played around by adding fields in the portal, placing them back, delete my portal again…..
 
The strangest thing that it suddenly worked again but I don’t know why. I didn’t change anything in the relationships, only in the layout.
I tried to add some more fields and now it doesn’t work anymore -again….
 
Does anyone knows why this is happening or what I am doing wrong?
Any help greatly appreciated.

Outcomes