3 Replies Latest reply on Jun 9, 2015 6:38 AM by philmodjunk

    Admin/blank-PW won't open file once uploaded to server

    jdevans

      Title

      Admin/blank-PW won't open file once uploaded to server

      Post

      I developed a prototype file, and wanted to show it to a colleague for a couple of issues we were working thru. It worked great while the file was located on my local machine, opening it without the need to Shift +Open, no password set for Full-Access.

      But once I uploaded it to server and I tried opening it there, it begs for a password which doesn't exist (to my knowledge). At least I know I never set one.

      Any idea what's going on here?

      Filemaker Pro 13 Adv, and FileMaker Server 13.  Windows environment on both.

        • 1. Re: Admin/blank-PW won't open file once uploaded to server
          philmodjunk

          So if you type in "admin" as the account name and leave the password box empty, you can't get the file to open?

          Have you checked File Options?

          If you download a copy to your local machine can you once again open it as before?

          • 2. Re: Admin/blank-PW won't open file once uploaded to server
            jdevans

            Strange. I don't know what happened, but I closed, then downloaded the file off the server. Opened from my desktop. (BTW, just to get it to work so others could see it yesterday, I gave the Admin account a password). Opened using the password I gave it yesterday successfully. Then went to Manage>Security>Accounts....cleared the password so that it is blank, saved and exited.

            Verified that the file could then be closed and re-opened on my local machine using the Admin Full-Access account successfully.

            Shared it back to the server in this configuration. Bingo, now it works.

            I suppose it needed some attention of some kind. This file was doing all sorts of weird things yesterday too. I have some scripts running, and was in the process of testing some of them. I had it working like I wanted before uploading to the server. But at that point, I never even went into the Manage>Security section at all, so at the point that I asked the question yesterday, that part of the file hadn't been changed from the time it was created.

            Works now. Back to the development drawing board.

            • 3. Re: Admin/blank-PW won't open file once uploaded to server
              philmodjunk

              Please note that a change in File Options--this is not in Manage | security, can alter this behavior.

              This file was doing all sorts of weird things yesterday too.

              That's really vague but perhaps your file is damaged. Run a recover on a recent copy and see if any issues are reported by the recover.