3 Replies Latest reply on Apr 6, 2012 4:48 AM by CPSEN

    All records skipped on import

    CPSEN

      Title

      All records skipped on import

      Post

      FMP/Dev v.10

      Trying to import records from an Excel file (.xls).  My table has no field validations set to "Always," there's no priviledge problems (I'm logged in as a full access user), and any fields set for "not empty" field validation in the FMP database have data in the import file.  I suspect it's something simple, but I'm going crazy.  Even tried converting it to a CSV file and importing that.  No love there either.

      Thanks for any suggestions.

        • 1. Re: All records skipped on import
          rmanook

          Hi CPSEN,

          Thanks for posting.

          Are you importing via a script/button or via File > Import records?

          Try importing via File > Import.  After selecting the source file (your excel file) and get to the Import Mapping window, can you verify that arrows icons are pointing from the source field to the specified target field?  There should be a field mapping key in the lower right corner of the window to serve as a guide.  The arrows indicate that the data from the source field will be imported into the specified target field.  If needed, you can click on the current icon to cycle through the options until the arrow icon appears.

          Also, are you adding new records or updating current records?

          Thanks,
          tsturtle
          FileMaker, Inc. 

          • 2. Re: All records skipped on import
            CPSEN

            Thanks tsturtle.

            Sorry, I should have been clear.  I am importing from the File -> Import menu, not a script.  And I have done the field mapping and checked the arrow to move the data into FMP.   Set to adding new records.  And I've tried performing and not performing auto-enter actions.  I see no field type mis-matches (I don't have any date fields in the source file, for example, just text and numbers).  I have a bit of experience with FMP so the basics are covered.  I've even read various articles or threads about this problem (lack of access priviledges (checked for both source and destination files), validation problems, etc.).  Nothing has worked yet.

            Only thing I can think of is the source file was created in Excel, but I'm using OpenOffice's Calc (though I'm using the .xls/Excel file type when I save the file).  So I went back to the original Excel file that was emailed to me and tried importing that.  Same problem.

            BTW, this is on a Mac running Snow Leopard.

            • 3. Re: All records skipped on import
              CPSEN

              Ahhh.  Egg on my face.  I just found one field that I don't often use that was set to Always validate as not empty, but I wasn't importing anything into it.  Hence the failure.  Oh, well, at least I figured it out.  Thanks again for the help.