7 Replies Latest reply on Jun 28, 2011 6:24 AM by SebastianBoldsen

    annoying auto format with copy paste

    CrystalWater

      Title

      annoying auto format with copy paste

      Post

      In 2009, I upgraded from FM pro 7 to version 10. Mostly it was a good upgrade, but what has been totally frustrating is the auto formatting of copy paste function when you copy formatted text out of another application and paste into Filemaker. It's so annoying because it overrides the formatting we set for that field not only in that layout but in ALL layouts through the entire database. Okay, maybe some people want to keep the formatting from a copy paste outside of filemaker, but I don't really see the purpose of it aside to annoyingly and mistakenly change all formatting we have taken tedious time to set in the layouts. What seems totally insane is that Filemaker does not have a setting to DISABLE this function and especially since it goes throughout all layouts not just the one you are on.

      From what I read online it seems in FMP 11 there is still no setting for this.

      So far I've found these ways semi-simple (hope this helps people having the same issue):

      -after copying a formatted text, paste into FM with option-command-V (kind of difficult to do with one hand)

      -after copying a formatted text, paste into FM with command-V, then immediately command-z (undo).

      -in manage database, click on the field in question (where you don't want to keep formatted text), selection options, Auto Enter Calculated value, TextFormatRemove ( Self ), make sure to uncheck do not replace. 

      I'm wondering if anyone has any good simple solutions to this aside from what I've found.

      PLEASE please please Filemaker, make a simple preference setting for this. After being a dedicated FM user for at least 15 years, this "feature" has been the most annoying thing considering that there is no preference and you have to do serious work arounds. Or if you don't do a setting, at least make it so that formatted pasted text only happens in that ONE layout and not in ALL layouts.

      Thanks.

        • 1. Re: annoying auto format with copy paste
          Sorbsbuster

          Using FM11, WinXP (and I understand you are using a Mac)

          I create a text field in Filemaker.  I create some text in Word and format it with a variety of font sizes and styles.  I select all the text and use Ctrl-V to paste it into the FM text field.  It displays in the format of the field.  In fact, if I right-click to see my options, the only option I have is 'Paste Unformatted Text'.

          I think any solution that involves 'Manage | Database' has to be considered a theoretical solution only...

          If your use of TextFormatRemove ( Self ) works, why do you not make that action a script, and trigger the script OnExit from that field?  If I manually format part of my pasted text and exit the field it sets the text back to unformatted.

          • 2. Re: annoying auto format with copy paste
            CrystalWater

            Yes, I'm on Mac so I'm not sure how it works on with WinXP version.

            The TextFormatRemove ( Self ) works great. It just means that you have to update all existing fields to do this. You don't even need to do any additional kind of script (except if you need to change previously created records). This is the best solution I've found.

            I actually just found that solution online today after more than a year of trying to find a good and simple solution. I wish I would have know about it longer because it probably would have saved me a lot of work.

            I just implemented it today in all the fields I needed and it works great. When you first paste a formatted text, it still comes up formatted, but when you exit the field the Auto Enter calculation does it work by replacing it with unformatted text and thus leaving the data with whatever formatting is already set by the layout for that field.

            This simple calculation works with easy implementation (I think even for people who don't know much more than the basics). I still would hope that Filemaker makes this as a preference setting because it just seems clumsy to assume everyone wants strangely formatted text overriding all their layouts.

            • 3. Re: annoying auto format with copy paste
              Sorbsbuster

              Sorry - I re-read your post more carefully: at first reading I came over all funny when I read one step in your work-around as involving [the user] "going to Manage | Database..."!

              • 4. Re: annoying auto format with copy paste
                CrystalWater

                Oh, yeah. It wouldn't be for the end user. The first two solutions could be though ( if you didn't opt for solution number 3 ).

                • 5. Re: annoying auto format with copy paste
                  Sorbsbuster

                  A 4th solution would be to add a 'Paste' button at the field and specify it as pasting without style, but the one you've chosen seems the best.  Personally, I'm used to selecting an 'option' to paste with or without formatting depending on which way I want it to look (be it into FM or Excel or whatever).  You can post your suggestion as a feature request, of course.

                  • 6. Re: annoying auto format with copy paste
                    philmodjunk

                    On windows xp, paste is actually "paste unformatted text", which is why it's automatically stripped out on that platfrom and not for Macs.

                    TextFormatRemove ( Self ) is the simplest solution I know of and does not require any scripting. It can easily be copy/pasted from one field's definition to another. (And if you have a lot of text fields where you want to enable this, you can set up one text field for this, then duplicate and rename it to rapidly generate a large number with exactly the same field options.)

                    A layout based setting that enables/disables this would be a great new feature in my opinion. If you'd like to make that suggestion where more Filemaker Inc. people will see it and evaluate it for possible inclusion: http://www.filemaker.com/company/feature_request.html

                    • 7. Re: annoying auto format with copy paste
                      SebastianBoldsen

                      I've tried using the TextFormatRemove ( Self ), but I have fields where I use "Auto-Enter" -> "Looked-up value", that allows the user to override the data entry, in which case I can't use the TextFormatRemove ( Self ), because I can't choose "Looked-up value" and "Calculated value" simultaneously. And it is necessary to have the option to edit the looked-up value manually still.

                      What I don't understand is why the Field Behaviour: "Set input method to": "Synchronize with fields font" doesn't work at all. (accessed in layout mode, by right-clicking the field)

                      Shouldn't this be able to fix that problem?