1 Reply Latest reply on Feb 22, 2011 10:05 AM by philmodjunk

    Another "Recover" Scenario

    RickWhitelaw

      Title

      Another "Recover" Scenario

      Post

      Hi,

          One of the files in my multi-file solution always "fails" the Recover operation. I've tried Recover on backups of this file from up to five years ago! They all come up with the same message. Here's how it goes. I try a Recover and the log reports problems. The "Recovered" version always creates two fields named "Recovered" and a table named the same. If I open the Recovered file and delete the created table and fields, then run Recover again, it comes up clean. 

          I only do this as an academic exercise since I have no problems whatsoever with this file. It just seems bizarre that when I delete the tables/fields CREATED by the Recover operation, then run Recover, it comes up clean, but the original file always reports problems. I haven't succumbed to replacing my file with the "clean" Recovered/Recovered version but I'm starting to consider the idea (of course with multiple backups in place).

      Opinions?

      RW

        • 1. Re: Another "Recover" Scenario
          philmodjunk

          Interesting. When I started reading this I wondered if you had encountered the "Differently aligned group" bug that can trigger recover to report a major problem with a file when none exists, but that would result in recover creating a new file.

          Have you tried using FMDiff on this file? It might tell you something that Recover doesn't.

          I've been there with this issue. "Do I spend many hours rebuilding the file or do I burn copious incense to Demon Murphy while hoping nothing catastrophic happens to my file"? The magnitude of the consequences for such a failure is usually the determining detail. If it's a file that won't bring business to a screeching halt and I have lots' of backups being made each day, I'm more likely to risk it.

          One thing to watch out for if you choose to continue to use the file as is: A new release, new update, change in platform may cause this file to go from "tolerating" the issue recover is tripping on to a major failure. I've seen such differences before and you just don't know...

          For those interested in reading about the bug I mentioned:   FMPA 10: group graphic + align = corrupt file?

          This is one of many acknowledged bugs that can be found in the Known Bug List here in the Report an Issue section of the forum.

          It can also be downloaded as a database file from:   http://www.4shared.com/file/8orL8apk/FMP_Bugs.html