4 Replies Latest reply on May 28, 2013 9:16 AM by MICHAELAE-V

    Auto enter data (on import) also happens with all New records

    JeanAnneMayhall

      Title

      Auto enter data (on import) also happens with all New records

      Post

      I use the file name of an excel spreadsheet as the auto enter DATA for records I am importing from the Excel file into Filemaker Pro. All is well.
      However, when I later create a NEW record in the same database, the auto enter DATA (in this case the file name of the Excel file) still populates the field...even though I am NOT importing. It confuses the accuracy of our Find for that particular excel filename because any new records entered also carry the same 'data'.
      What am I doing wrong?
      The only way I can see to stop that 'data' from auto entering with each new record is to erase it from the data desciption box in the auto enter menu? That can't be right?
      Jean Anne

        • 1. Re: Auto enter data (on import) also happens with all New records
          davidanders

          When you import records they become the found set.

          If the import is done with a script, the script could Replace the Contents of the field in the found set with the imported Excel Filename.
          This could be done manually, also.
          No auto-enter required, new records would have that field blank.

          The other option would be to create a column in the Excel spreadsheet for that field name and fill that column with the Excel Filename before import.

          I am sure there are four other options, but those two spring to mind.

          David Anders
          The Computer Guy, Seattle

          • 2. Re: Auto enter data (on import) also happens with all New records
            JeanAnneMayhall

            Thanks Dave.
            I did think of those ideas....and thanks for reinforcing.  I will give then a try.

            I am hoping someone from FM will write back and confirm to me my issue...which is that even though you designate a piece of auto-enter data in the middle of an import process only, it continues to auto enter that data on every new record (until you remove or replace it.)  That doesn't seem right, but I guess that is what happens.

            Jean Anne

            • 3. Re: Auto enter data (on import) also happens with all New records
              philmodjunk

              Auto-enter settings kick in whenever a new record is created. This includes records created by import records only if auto-enter options are specifically enabled, but this is an all or nothing proposition--either all auto-enter options for all fields in the table are enabled or none of them are. Thus work arounds like those DavidAnders has already described are the typical methods used to load data into a field during import and not when a new record is added through other means.

              • 4. Re: Auto enter data (on import) also happens with all New records
                MICHAELAE-V
                       
                •           
                            
                       
                •      
                •           
                                        
                  •                          Permalink
                  •                
                            

                                                I have done a file maker pro data base, some thing has gone wrong, it all worked before can some one help me.

                                                I have client list a product list and an invoice list.

                                                 

                                                When I try to enter a product  code and name in my invoice (I san see the product name which comes from my product list)

                                                It comes up with a warning saying   " This field cannot be modified until “” is given a valid value.:

                                                 

                                                I cant get it to work it used to very odd see image

                       
                •      
                •           MICHAELA E-V