1 2 3 Previous Next 30 Replies Latest reply on Oct 11, 2011 1:24 PM by ChristianNorland

    Autopopulate Not Working Correctly

    kingsley47

      Title

      Autopopulate Not Working Correctly

      Post

      Basically I have a test report that is supposed to autopopulate every single field based on what is typed into a field called "Work_Order_Number" This is supposed to work using a look-up value. I have had zero issues with the fields that are directly dependent upon the "Work_Order_Number" field for the search reference between the test report database and the related databases. However, about half of the fields of my test reports are dependent upon a different search criteria, that search reference is a field called "Material_Specification". The "Material_Specification" field is actually a look up value that uses "Work_Order_Number" as its search reference.

      All of the fields that use "Material_Specification" as a search reference, do not get populated immediatly. To get them to populate, I need to click into any of the blank fields, then click in the "Material_Specification" field and re-type a portion of the information in that field. (Deleting one letter and then re-typing it is all that needs to be done) I have tried changing the "Material_Specification" to a calculation field that states the correct information as text. This doesn't fix the issue. I have tried making the other fields calculation fields but this also doesn't fix the issue.

      Does anyone know what I am doing incorrectly here?

        • 1. Re: Autopopulate Not Working Correctly
          philmodjunk

          The two part look up where a value is looked up and then serves as a key for the second look up doesn't seem to work in current versions of Filemaker like it once did in much older versions.

          Instead of retyping the value, relookup might also work, but this update all the records in your found set, so you may incur significant delays unless you only have one record in your found set at the time you select this option.

          You might try setting up an OnObjectSave script trigger on the Work_Order_number field to perform a script that triggers the second stage of your look up automatically.

          You might also consider whether you need to look up all these values into matching fields at all. In many cases, you can add fields from the related table to your layout instead of copying over the data. The key difference is that if you use the fields from the related table instead of looked up values, an update to the related record will automatically appear on the current layout where this will not happen when use use the looked up value option.

          • 2. Re: Autopopulate Not Working Correctly
            kingsley47

            I just tried replacing the look up value fields with fields from the related table and I still had the same issue of not having any fields pop up until I recommitted a portion of the Material_Specification field.

             

            I am going to try the on object save script trigger method. Could you tell me how to get started with this one? This is what I tried but it did not work.

             

            On object save (Work_Order_Number)

            Insert Calculated Result [Select;MTRS::Yield_Req.;Material Requirements::Yield_Requirements]

             

            I only did it for one field to see if it would work. In actuality, this script would repeat the same thing for about 40 different fields all one right after the other.

                    

            • 3. Re: Autopopulate Not Working Correctly
              philmodjunk

              Did your work?

              If so, change the insert step to:

              Set Fieild [MTRS::Yield_Req.;Material Requirements::Yield_Requirements]

              Set field is a better option here than insert calculated result.

              Going back to using related fields on the layout. This should work, but you may need to commit the record (not re-edit the field). See what happens if you place one of these fields on your layout, enter the Work Order Number and then click a blank area of your layout to commit the record. Do the values appear? If so, you just need to add a commit record step to an onObjectSave trigger on the work order number field so that selecting/entering a value automatically commits the current record. This may be needed to force the lookup of a value into the Material_Specification field.

              • 4. Re: Autopopulate Not Working Correctly
                kingsley47

                Unfortunately neither the calculated result nor the set field option worked.

                I also tried to commit the record to to get the related field windows to work. What I did was make a script whose only function was

                 

                on object save (Work_Order_Number)

                Commit Records/Requests [No Dialog]

                 

                This also did not work to get either the look up values or the related field windows to work.

                 

                One very strange thing that I've noticed is that I'm not having this problem all of the time. This issue seems to only come up when I'm reffering to records in my Material Requirements database, that were made early on, specifically before I remotely connected the Material Requirements database to my MTRS Database. Any records I reference from Material Requirements, that were created after I did that, do not seem to have this problem.

                • 5. Re: Autopopulate Not Working Correctly
                  philmodjunk

                  You may have a field index that has gone bad.

                  To rebuild the index of a single field:

                  1. Open Manage | Database | Fields and double click the field
                  2. Use either the storage tab or the storage options button to turn off indexing.
                  3. Exit Manage | Database, then return and turn indexing back on.

                   

                  You can also rebuild all your file's indexes by importing all the data into an empty copy (clone) of your file.

                  If you have FileMaker 11, you can use Advanced Recovery options to rebuild your file's indexes:

                  1. With the file closed, select Recover from the File Menu.
                  2. Select "Use advanced Options"
                  3. Select only: "Copy File Blocks as-is" and "Rebuild Field Indexes Now".
                  • 6. Re: Autopopulate Not Working Correctly
                    kingsley47

                    Which field should I be trying to rebuild? The Material Specification Field in my MTRS database or the Material Specification field in my Material Requirements database?

                    • 7. Re: Autopopulate Not Working Correctly
                      philmodjunk

                      Both.

                      Best option is to use Advanced recovery options on both files to rebuild all the field indexes...

                      • 8. Re: Autopopulate Not Working Correctly
                        kingsley47

                        So, I've been trying to read up on filemaker server because I have all of these files hosted through server and there isn't an option, that I saw, to get to a remote file in the advanced recovery options. I am not very familiar with server at all, I basically use it to automatically back up our files.

                         

                        How do I get to the "final" version of the file if I can't get to it remotely through advanced recovery options?

                        • 9. Re: Autopopulate Not Working Correctly
                          philmodjunk

                          To do a recover, you have to take the file down from the server and put it on your machine where you can get at it to do this. It's often easiest to use a back up copy of the file created by the server admin as this way, you do not interrupt access to your database while doing this test.

                          • 10. Re: Autopopulate Not Working Correctly
                            kingsley47

                            I recovered backups of both my databases and then went through the steps to pull up the correct information....still nothing.....not sure where to go from here.

                            • 11. Re: Autopopulate Not Working Correctly
                              philmodjunk

                              I think I'd need to see a copy of your file to investigate further. You can save a clone (no records) and upload it to a file sharing site if you'd like me to take a quick look. I'll need admin access to the file so that I can check the structure and relationship details to be able to offer any insight on this.

                              • 12. Re: Autopopulate Not Working Correctly
                                kingsley47

                                I have uploaded the cloned files to www.4shared.com. My username is bkingsley@usbolt.com. Not sure if you would need anything else to find the files I uploaded.

                                • 13. Re: Autopopulate Not Working Correctly
                                  philmodjunk

                                  Best method is to copy and post the download link here. Then a click on that link or a copy and paste into a browser URL box pops up the download screen for your file. If the file has a password defined, I'll need to know that.

                                  1 2 3 Previous Next