5 Replies Latest reply on Sep 10, 2013 10:08 AM by Fred(CH)

    Bold style appears "double bold"

    ThomasStaehli

      Title

      Bold style appears "double bold"

      Post

      Hello, 

       

      Some of my users (mac users) and myself started to have some problems with some printing layouts. The font used appears ok except on the parts in bold which appear like twice as bold as it should be.

       

      I made some tests comparing with Microsoft Word and here's the conclusion I arrived to:

       

      Whith some fonts (I tried with Arial, Verdana and Trebuchet MS), when you put a bold style (directly on the layout or in a calculation field), filemaker takes actually the bold version of the font and adds a bold style on it => double bold. 

       

      Here's an example how it looks like in word (and how it used to look like in filemaker) 

       

      Arial with bold style in Word

       

       

      And here's an example of how it looks like in filemaker 

       

      Arial with bold style in Filemaker 

       

       

      Of course I could change all my layouts and choose the bold font instead of the normal one with bold style, but I don't really like that idea.

      One solution I found is to delete all the font files (.ttf) with a style included and leave only the regular one. But again, I don't really want to do that on all the users computers.

       

      Does anybody have a solution to this? The bug appears on both Leopard and snow leopard and with filemaker 9 or 10. 

       

      Thanks a lot

       

      Thomas 

        • 1. Re: Bold style appears "double bold"
          rethinkmedia

          Hi Thomas, I don't have a solution to this problem but I have also discovered it, and documented it thoroughly in hopes that the bug will be understood and escalated.

           

          Here is my post on the subject.  Does that sound like the same problem you're having?

           

          http://forum-en.filemaker.com/t5/Report-a-bug/Continuing-Font-Issues/m-p/62026#M7240

           

          Daniel

          • 2. Re: Bold style appears "double bold"
            ThomasStaehli

            Hi thanks for your answer. It's good to see I'm not alone :-)

             

            Yes it's exactly the same problem I'm having. 

            • 3. Re: Bold style appears "double bold"
              kenfromboston

              Hi,

              It's about 1.5 years after this post, but I think I know what's happening, and I seem to have a workaround.  The "double bold" problem seems to occur if you have clicked the "bold" button to make text bold for a font that has a bold variant.  Thomas, I checked Arial, and it has a bold variant, as does Times New Roman, the font I was using when I just encountered this same problem.  The way I fixed it was to go to the font dropdown and select the bold variant of the font (I originally had Times New Roman selected as my font, so I changed it to Times New Roman Bold).  Then, TURN OFF the bold attribute button, and this should fix the problem.  My guess is that this is a bug, and what's happening is the when the "bold" button is seen as pressed, not only is the bold variant of the specified font used, but some other sort of "bold" operation, that is probably used for fonts that don't have a bold variant, is also applied.  I'm sure this is too late for the previous posters to this thread, but I hope that this information may help others who encounter this problem.  FYI, I encountered the "double bold" problem in Filemaker Pro Advanced version 11.0v2, running on Mac OS X 10.5.8 on a PowerPC Powerbook G4.

              p.s.  I also just discovered that there is a similar problem with italicized text.  I had some text that was both bold and italicized, and when I was fixing the bold problem, I noticed that Times New Roman (the font I was using) had a "bold italic" variant.  I switched to that and turned off the "italics" button on the toolbar, and discovered that just as the bold text was "double bold", italicized text for fonts with an italics variant seemed to be "double italicized", and was corrected with a change to the italics variant and turning off explicit italics on the toolbar.

              Ken

              • 4. Re: Bold style appears "double bold"
                RolfNoyer

                I have found the same problem, both for Bold and Italics, and am glad I am not alone.

                Does anyone know how to solve this problem when the formatting is introduced through a calculation? For example if I write in my calculation

                TextStyleAdd ( text ; Italic)

                then I appear to be getting in some instances a slanted version of the Roman, not the Italic, and in other instances the "double" Italic, which is really a slanted version of the Italic font.

                It's important to understand that there are two ways in which macs seem to deal with formatting commands. They can simulate italics and bold for fonts which lack specific italic and bold versions, or they can substitute the specifically italic or bold version if it is present in the system.  FileMaker seems to want to do both at once. Right now my fix is to use the "Roman" version of a font which is Italic. But there are only certain fonts whose Italic version FileMaker seems to recognize in a calculation. For example I can write

                TextFont (text; ItalicFontName)

                only for certain fonts which lack Roman versions, that is, which are inherently and only italic fonts.

                Would TextFontRemove somehow make it all better, if used correctly?

                • 5. Re: Bold style appears "double bold"
                  Fred(CH)

                       Hello there,

                       I just posted another occurrence here :

                  Double styled TrueType and OpenType fonts on Mac OS X

                       Bye, Fred