8 Replies Latest reply on Dec 11, 2009 1:54 PM by TWE

    Border spacing in field

    HugoLidia

      Title

      Border spacing in field

      Post

      Can a border space of say 1 character be set for every field by default?  We notice that if a field has a border around it the first letter of any text entered is hard up against the border and we'd prefer a space of a few millimeters or maybe just one character.  Troule with having it set to one character would be depending on font size and type the space size would be different and should be uniform.

        • 1. Re: Border spacing in field
          bumper
            

          In Layout Mode go to Format>Text click on the Paragraph button, select your indents Left and Right. Most use 2 to 4 pixels each side.

           

          HTH 

          • 2. Re: Border spacing in field
            HugoLidia
               But can this be set to be global
            • 3. Re: Border spacing in field
              bumper
                  Yes. It's late but I believe that it's only fields formatted as radio buttons don't show indents correctly.
              • 4. Re: Border spacing in field
                StellaLuna
                  

                HugoLidia wrote:
                But can this be set to be global

                It might mean that someone wants to set a default so all new fields have this indent automtically.  If so, yes you can.  In layout mode, don't select anything and go to format then set your indents.  That is how to set defaults on fields, fonts etc.


                • 5. Re: Border spacing in field
                  HugoLidia
                    

                  The indents suggestion does not work.  Is this because it has to be set before any data is entered into any fields or before the tables are set up?

                  Also, how does one change the indents to be in pixels as opposed to cm?

                  • 6. Re: Border spacing in field
                    philmodjunk
                      

                    This should work for you and it doesn't matter whether you set the format option before or after you define the field. This is a format applied to a specific instance of the field on the current layout only--unless you follow Stella Luna's advice for setting a default that will apply to each new field you place on a layout.

                     

                    The units thing is one of Filemaker's more clunky features that I'd like to see updated in future releases. To change the units, pull up the Object Info palette and click on the units shown--cycling through different units with each click--until you see the units you want. Now select the field and Use Format | Text...|Paragraph to pull up the dialog with indents and you should see the same units you selected in Object Info.

                     

                    Here's the step by step to indent the text two pixels (to indent the width of one character will need a few more pixels).

                    1. Enter layout mode
                    2. Use the object info palette to select Pixels for units.
                    3. Select the field
                    4. Select Format | Text | Paragraph
                    5. Enter 2 in the "Left" indent box.
                    6. Click OK and return to browse mode.
                    • 7. Re: Border spacing in field
                      HugoLidia
                         Finally got around to testing your suggestions - thanks to StellaLuna & PhilModJunk, both work and are applicable to different situations.
                      • 8. Re: Border spacing in field
                        TWE
                          

                        I believe IWP table view has a problem with this. I tried setting the left indent as directed (0.10 in, big enough to easily see) using FileMaker Pro (I did an open remote to get FileMaker Server 10 Advanced's version). When I went to my browser (FireFox 3.5.5), brought up the Instant Web Publishing version of the database, and set the view to table, the left indent was ignored. This is especially a problem with digits. It is hard to distinguish a 3 from an 8. There should be at least 1 pixel of indent in table view. The harder alternative is to follow the setting specified by Text...-> Paragraph -> Left Indent.