3 Replies Latest reply on Jan 30, 2013 7:32 PM by VanessaAnne

    Can Container fields be used with related tables between databases?

    MikeHarrison

      Title

      Can Container fields be used with related tables between databases?

      Post

      In one database, I have a portal that references records in another database. I want to establish a container field to display an image in each record. (ie: a computer inventory database, I would like an actual picture of the computer type next to it, how that works is beside the point.) The issue is that when I try to establish the table relationship between the two fields (a "picture" container field), it's grayed out and won't let me make the relationship. 

        • 1. Re: Can Container fields be used with related tables between databases?
          philmodjunk

          "database" is a very fuzzy term in FileMaker land. ("Database can refer to a single file or many files, a single table or many tables so the term can confuse people unless additional info is provided to tell them what you mean.)

          You can establish such a relationship, but you do not use the container field as a key in that relationship. You'd match by a different pair of fields and then you can use that relationship to refer to and display the container field. In your case, you'd match a pair of Computer Type fields to get a relationship like this:

          Inventory::ComputerType = ImageTable::ComputerType

          Then you can add the container field from ImageTable to a layout based on Inventory.

          • 2. Re: Can Container fields be used with related tables between databases?
            MikeHarrison

            Thanks, I was over-thinking it and did what you suggested.

            • 3. Re: Can Container fields be used with related tables between databases?
              VanessaAnne

                   Hello, 

                   I just tried this but it didn't work. 

                   I want images to auto populate based on another field with titles for those pictures.  I have a separate database that contains all the photos and the same title name that is in my main database.  I have set it up so the main database relates to the photo one and linked up the titles field so they are equal. 

                   Please let me know what I'm missing.  Nothing is happening, it doesn't show up gray it shows up black. 

                    

                   Attached is an image of the set up I've done to establish the relationship.