8 Replies Latest reply on Jun 21, 2010 8:05 AM by TSRaven

    Can't Access my IWP database remotely

    jmnelson83

      Title

      Can't Access my IWP database remotely

      Post

      Using Filemaker Pro 10 and am trying to host my database via IWP.  I can access it when I am within the same LAN from a different machine, but I have not been able to access it remotely over the web.  I am an IT novice, but I suspect security settings on my remote server/network are prohibiting access.  Any help is appreciated.

       

      Thanks

        • 1. Re: Can't Access my IWP database remotely
          PointInSpace

          You probably need to enable port forwarding on your router for port 80 to the internal IP of your host machine.

           

          - John

          • 2. Re: Can't Access my IWP database remotely
            jmnelson83

            Thanks for the quick help.  I'll try that. 

            • 3. Re: Can't Access my IWP database remotely
              jmnelson83

              I enabled port forwarding for port 80, and still no luck with any remote access.  I get the following message when trying to access remotely:  "The Server is taking too long to respond."

               

              Any other suggestions are appreciated.

               

               

              • 4. Re: Can't Access my IWP database remotely
                davidanders

                http://speedtest.net

                will show the internet access speed of your computers

                WinXP, Vista, Win7, OSX?

                Browser being used

                Version of Filemaker (Pro, Adv, Server, ver10...)

                Pinging the remote computer also can provide info.

                RAM in the hosting computer?

                Size of the database.

                Response time on the same LAN?

                There are many variables.

                 

                • 5. Re: Can't Access my IWP database remotely
                  jmnelson83

                  I have a feeling it is a setting with my host machine, because I've tried hosting from my home computer and my work computer and each time I've had no problem accessing the db (very small) through IWP on other machines within the same network, but no luck when trying to access remotely.  I've tried all the port forwarding on my home Linksys WRT54GS and that hasn't helped.  Is there a firewall or security setting that I am missing?  I have a cable modem and my ISP is Time Warner if that means anything.

                   

                  Thanks for the help.

                  • 6. Re: Can't Access my IWP database remotely
                    jmnelson83

                    Okay, through some more research and trouble shooting, I have done the following:

                     

                    • Enabled my firewall to allow outside access for FM.
                    • Forwarded ports 5003, 80, 591 to my internal IP
                    • From my remote computer, I have pinged my external IP with success (round trip avg at 1161ms)
                    • When I have my DB hosted via port 591, I cannot ping the appended IP (i.e. xxx:591) remotely or locally - I'm not a networking guy, so maybe this doesn't matter and can't be done
                    • I assume my IP is not static, but it has remained constant every time I checked, so for testing purposes, I should be okay
                    • I've come accross other info that says I need to forward additional ports (50003, 50006) not sure if that is the problem
                    • When I try to log in remotely I get a "server timed out" error - I am logging in using the external IP of my host machine/router

                    I feel like there is a simple solution I am missing.  Please Help!

                     

                    Much appreciated.

                     

                    • 7. Re: Can't Access my IWP database remotely
                      fitch

                      The only port you need to forward is 80, unless you've specified a different port (591) in IWP sharing options.

                       

                      Those other ports are for FMP client/server communications.

                      • 8. Re: Can't Access my IWP database remotely

                        jmnelson83:

                         

                        Thanks for your post.

                         

                        As other users in this thread have sugested port 80 is the default port for IWP and normally the only one that you need to focus on. The only exception is when antoher sevice (such as Apache or IIS) is taking up that port, in which case port 591 is our preferred alternate port. As this works in your LAN and not when accessing remotely from outside of it the issue is more than likely with your router communication to your system.

                         

                        Depending on whether you are using Windows or Mac based there are a couple ways to make sure the router is getting the signal. Ping only works on the base IP, not on specific ports, but Mac systems allow you to scan a specific port. If you have a Mac available use the port scan function of your Network utility inside the Applications/Utilities folder. Scan the IP and check the box to scan only specific ports, entering the port you want to scan in both boxes.

                         

                        On Windows you can also try to use telnet rather than ping (telnet <ip>:<port>). If the Windows component for telnet is enabled it will either give you a blank screen with a cursor for a couple minutes and then time out, or return an error that communication could not be established. Note that if it designates communication can't be established on port 22 this means the port telnet listens with is blocked/closed, and it has not yet tested the port designated in the command entry. In this event you will need to enable the telnet service and make sure port 22 is open in your system and network. Port forwarding may also need to be set up for this port if trying to access from outside the local netowrk.

                         

                        Alternately, verify the port forwarding is set up correctly in your router to forward requests to the correct internal IP on the port designated in your IWP options. Use the URL http://<external IP address>:80<or 591>/fmi/iwp.

                         

                        Please keep me updated with any additional information or questions.

                         

                        TSRaven,

                        Filemaker Inc.