2 Replies Latest reply on Jan 5, 2013 2:49 AM by mickwilli

    Can't Print Envelopes - Prints on A4 Instead

    mickwilli

      Title

      Can't Print Envelopes - Prints on A4 Instead

      Post

            

      Hi All,

      I've just noticed an pretty big issue that could be a bit of a show stopper for us in a new database that I've been working on.

      I have a layout specially setup in Filemaker for printing DL Envelopes. This has worked perfectly fine in previous versions of Filemaker (currently the system I'm re-writing is running just fine under Filemaker 11). Under Filemaker Pro 12 (Advanced) when I print the envelope layout the printer receives an A4 page to print rather then the DL Envelope page as set in the print setup dialogue (as specified in my script). I've tried specifying the print setup manually and then printing the layout manually, but this appears to have no impact.

      The printed output prints the layout correctly in the bottom left hand corner of the A4 page so there is definitely something wrong with the instruction the printer is getting.

      I’ve only done limited testing so far when I briefly popped into work today to test print the layouts to ensure they print correctly. The machine I was using is a Mac OS X 10.7 machine with Filemaker Pro 12.3 Advanced. The two printers I’ve tried are a HP 4200 and a HP M2727. I’ve not had a chance to really test this right down to the nitty gritty, but it screams of a Filemaker bug to me.

      Printing envelops is a pretty big part of what we use Filemaker for, so it’s pretty crippling to not be able to do it. I was wondering if someone else had come into any issues with this in Filemaker 12 and if anyone else could maybe try doing a test print to their printer with a DL Envelope print setup.

      Thanks,

      Michael

        • 1. Re: Can't Print Envelopes - Prints on A4 Instead
          philmodjunk

               In previous versions of FileMaker, I've seen this once or twice where a layout seems to get "stuck" on a specific page size and you can't seem to change it to a different size for correct printing.

               Try creating a new layout. It doesn't have to be fancy, but create it from scratch--don't copy and paste layout objects from the problem layout, and try printing to an envelope paper size from it.

               If this works, then your layout may be damaged. You can replace that layout with a new one or you might try advanced recovery options to see if that corrects the issue:

               Select:

               "Copy File Blocks As-Is"
               "Delete cached settings"

               While I usually recommend against using a recovered copy of a file, this is an except given the very limited changes it will make to your file.

          • 2. Re: Can't Print Envelopes - Prints on A4 Instead
            mickwilli

                  

            Hi Phil,

            Thanks for your advise and you were close....

            After much profanity and other expletives I’ve discovered what the offending component was. For some reason my two scripts that I was using to print the two separate envelope layouts (one script was a modified duplicate of the other) were poisoned. I could not see any logical reason for either of these scripts to fail.

            What I ended up doing in the end was creating a new blank Filemaker file and wrote out the script again, including the page setup info. It has all the same script steps as the scripts that didn’t work. I then tested this in the new file and it worked ok. Then I created a new script in the main file and copied the script steps into that script. This works just fine now.

            The only thought that is different is that I did all this while I was at work where the computer would have been able to talk to the printer, should it wanted to, whereas I setup the initial scripts at home and the computer wouldn’t have been able to contact the printer. Not that I’d imagine that would matter.