AnsweredAssumed Answered

Can't seem to get Perform Find to work

Question asked by AntonioRivera on Jul 21, 2015
Latest reply on Jul 21, 2015 by SteveMartino

Title

Can't seem to get Perform Find to work

Post

I'm relatively new to Filemaker (v.14) and still learning a lot. I've written a script to perform a find for me for all records with a SUB_ID > 0. I've written the following script - which doesn't work by the way.

----- start of script

Enter Find Mode [ Restore ] <-- I've specified a Find Request inside for SUB_ID with criteria > 0.

If [ Get (FoundCount) > 0 ]

   Enter Browse Mode [ ]

   Go to Layout [ "Report EOD-X Report" (Orders) ]

   Sort Records [ Restore; No Dialog ]

Else

   Go to Layout ["Main Menu" (Orders) ]

   Show Custom Dialog [ "Information"; "Found no records to report." ]

End if

Enter Browse Mode [ ]

Show All Records

----- end of script

When I run the script I still get unwanted records where the SUB_ID isn't > 0. But when I do a PERFORM FIND from Filemaker and manually enter "> 0" in the SUB_ID field. I get the right output. What am I doing wrong?

Thank you in advance.

 

Antonio

 

Outcomes