1 Reply Latest reply on Mar 1, 2011 8:28 AM by philmodjunk

    Can't Turn Off Auto-Resort

    DanBurn

      Title

      Can't Turn Off Auto-Resort

      Post

      When will Filemaker make a switch to turn the auto sort off? Why didn't they think to just have a simple button to inactivate it? I see people have posted stuff about it in 2009 and as far as I can see theres still no way to switch it off.

      Or is there a way? Please help.


      Its driving me crazy, every time I alter a field it resorts it to somewhere and I can't change the other fields. Sometimes it just gets lost in my vast data base, as I can't remember what the name of the contact was and now theres no way to find it.

        • 1. Re: Can't Turn Off Auto-Resort
          philmodjunk

          Yep, this is an ongoing irritation in current versions of FileMaker. You are welcome to post this also to: http://www.filemaker.com/company/feature_request.html

          I'm told there are people at FileMaker Inc. that pay close attention to the suggestions made there. Maybe if enough of us request this feature, they'll finally do something about it.

          I can suggest two work arounds for this.

          One is to either unsort the records prior to editing or sort them specifying fields that aren't accessible on the layout for editing. Can't do either in many cases, but if you can, that's the simplest fix to avoid "jumping records".

          Another options is to use a paused script to disable the auto sort. Add a button called "edit mode". When the user clicks this button it performs a script that includes the pause/resume script to pause the script indefinitely. If you disable user abort, your users can't cancel this script while it is paused by clicking cancel in the status area. When editing is finished, another button can use halt script to cancel this paused script and the sort will once again update.