2 Replies Latest reply on Oct 23, 2013 1:45 PM by jmageean

    Cannot see fields that I have created

    jmageean

      Title

      Cannot see fields that I have created

      Post

           .  I built my DB tables using the DB Manager (a lot of tables).  Each with auto index fields plus related index fields and all the general table fields.  I then built my relationships using the relationship graph.  Everything seemed to fit together nicely.  However, when I tried to construct my layouts I have run into  a problem.  Only two of my tables show all of the fields.  The other tables only show their auto index fields.  (However, everything is there when viewed in the Data Base Manager)  So I looked at one of the tables missing the fields in the browse mode.  The auto index field shows.  I tried manually adding another field which it did.  The number of the added blank field was 15 suggesting that the fields I built into the table are there just not shown.  I tried deleting some of the relationships to see if the relationship connections were causing the fields to be hidden.  Can you suggest something that I am doing to cause this?

        • 1. Re: Cannot see fields that I have created
          philmodjunk

               Layouts and Tables are two different things even though they often have exactly the same names.

               FileMaker does not necessarily add a new field to a layout at the time you define it. Often, you have to use the field tool to add it to the layout or, in table view, use the modify button to add it to the view.

               There's a preference setting in Edit | Preferences that controls this. It only adds a field to the current layout so if you are on a layout for Table A and use manage database to add fields to table B, they won't show on the layout for Table B even if this option is selected.

               Given that detail and the fact that you can't control where the fields are added on the current layout, I find it easier to leave that option disabled and then use the layout tools to add fields where and when i want them.

          • 2. Re: Cannot see fields that I have created
            jmageean

                 Thanks.  Your answer gave me the solution to my problem