0 Replies Latest reply on Oct 9, 2010 11:49 AM by KBGF75

    Cannot share files because another user is already sharing

    KBGF75

      Title

      Cannot share files because another user is already sharing

      Post

      For a long while I have been using FMP9 and Instant Web Publishing to share a database. Recently I deactivated FMP9 on computer A (Windows Vista) and then activated it on networked computer B (Win 7). That process went smoothly. When I opened the current FMP file on B, I got an error message: "Filemaker cannot share files because another user is already sharing files using Filemaker Pro on this computer".  (I’ve seen this error before, and somehow I muddled through to overcome it…but I can’t say how.)

      So IWP no longer  works. A web browser with the correct URL does connect to computer B (shows Instant Web Publishing, Database Homepage), but the page also shows “No databases available.”

      I looked in this Forum for a posting that seemed relevant and found the following from 2009:   

          Error message: "Filemaker cannot share files because another user is already sharing...." I had been sharing my filemaker pro database, using FM9, with several computers over our network.  I shut down the database, as I do periodically, to do a backup, but when I restarted the database, I got the error message: "Filemaker cannot share files because another user is already sharing files using Filemaker Pro on this computer".  I shut everything down and restarted the computer, but I still get the message.  There is only one user on this computer, and no other files are being shared using Filemaker.  Does anybody have any idea what I might be doing wrong?

          Response posted 10/8/09 by SWS: There are also 2 other possible causes for this issue:

          1. a corrupt certificate file, I now provide links to download these files to my clients as required server.pem and root.pem in the Filemaker folder Im not sure im allowed to post links to files on here so have sent you a private message with the files

          2. Under networking connection options (right click on network adapter and choose properties) turn off TCP/IP Version 6 (TCP/IPv6) leave V4 enabled   I have come across this situation a lot, and one or both of the above has worked every time.

      I tried to follow the steps in response #2 but could not find corresponding choices in Win 7 Networking. Maybe the suggested action was based on an earlier OS, perhaps my inexperience. Help is needed.